Find the answer to your Linux question:
Results 1 to 7 of 7
I have been on a personal project for several weeks now. I am trying to get Half Life 2/Counter Strike to run on FC3. I can get the accual game ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    cedega and ATI driver problems


    I have been on a personal project for several weeks now. I am trying to get Half Life 2/Counter Strike to run on FC3. I can get the accual game to run but because of driver issues it ran at 4 fps no matter what the video settings are. I can run it at 600 X 800 with low settings for everything or 1024 X 768 with high settings for everything and it will still run at 4 fps. So after this i realized i that the 3d rendering wasnt enabled on my system and after I ran fglrxconfig, i got the 3d enabled and running but the game wouldnt start, all i would get was a black screen and nothing happened. So, i reinstalled with all generic drivers just to test things out with the generic drivers and nothing worked for that. So, i reinstalled ATI drivers and now i cant get the 3d working again. This is confusing the heck out of me. I know ATI drivers suck in linux but i know people have gotten it to work. Can someone help me?

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    what ATI card have you? If it's the 7000 series, then yes that's about it. If it's from a later series then visit ATI's site and get yourself a copy of their driver, which should help.

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    i have a 9600 xt and, i already have the latest drivers installed but cant get fglrxconfig to work properly

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    sorry, can't help you there.

    Suggest you try a post with a title something like "Need help getting fglrxconfig to work with ATI driver" or something like that. That way you'll attract the right kind of helpers.

    good luck

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by metacortex
    i have a 9600 xt and, i already have the latest drivers installed but cant get fglrxconfig to work properly
    Can you start X at all with glx enabled? What do you mean by "can't get fglrxconfig to work properly"? Does it fail to finish or does it just not produce a workable config?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    if fglrxconfig don't work u may need to reinstall ati driver that's what i did and it worked for me

  7. #7
    jvx
    jvx is offline
    Just Joined!
    Join Date
    Sep 2004
    Location
    Estonia
    Posts
    77
    Did you run fglrxconfig with root user? If not, then do it!
    Defunk got his ATI 9600 Pro to work, doing this: http://www.linuxforums.org/forum/top...tml&highlight=

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •