Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
The sound in doom 3 is garbled I was wondering has anyone had this problem and actually fixed it and if so how. I am running the patch from idsoftware. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Philadelphia/PA
    Posts
    21

    Doom 3 sound garbled


    The sound in doom 3 is garbled I was wondering has anyone had this problem and actually fixed it and if so how. I am running the patch from idsoftware. Video looks great just the sound is garbled/scratchy. My sound card shows up as snd-intel8x0 on Mandy 10.2.

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    I had what sounds like a similar problem on Fedora Core 4 recently with the latest 1.3 client from Id. What sound system are you using (choose it in the System menu)? I found that when I changed from Alsa to OSS and relaunched the game the sound cleared up.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    May 2005
    Location
    Philadelphia/PA
    Posts
    21
    I switched to oss and now I have no sound.

  4. #4
    Just Joined!
    Join Date
    May 2005
    Location
    Philadelphia/PA
    Posts
    21
    Could you post your doomconfig that might help a little

  5. #5
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    I'll do that the next time I'm on my home computer.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  6. #6
    Just Joined!
    Join Date
    Jun 2005
    Location
    Virginia, USA
    Posts
    32
    Just load up Doom3 again and you'll be set. Moe gave you two instructions, and you didn't follow the second one.

  7. #7
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Quote Originally Posted by Rouser
    I switched to oss and now I have no sound.
    Have you got OSS compiled into your kernel? If not do so:
    Code:
    su
    [rootpass]
    cd /usr/src/linux
    make menuconfig
    here go to
    Device Drivers ---> Sound ---> Open Sound System ---> and then select the driver for your sound card and then press Esc untill you are asked if you want to save, select to save. Now:
    Code:
    make && make modules_install
    now oss should work on your system.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #8
    Just Joined!
    Join Date
    May 2005
    Location
    Philadelphia/PA
    Posts
    21
    OSS is already compled in the kernel and I have restarted the game still no sound.

  9. #9
    Just Joined!
    Join Date
    Jun 2005
    Location
    Virginia, USA
    Posts
    32
    Quote Originally Posted by Rouser
    OSS is already compled in the kernel and I have restarted the game still no sound.
    Oh, sorry, my fault on that diagnosis. I had the exact same problem as you, as the "alsa" and "best" settings gave me garbled sound. I then set it to OSS, and my sound disappeared entirely as you describe and I got pissed. I then simply restarted Doom3 and all was well, except for the abysmal peroformance, courtesy of ATI Linux drivers.

    PS: try setting your multimedia selector to "OSS" as well, don't know if that will do anything.

  10. #10
    Just Joined!
    Join Date
    May 2005
    Location
    Philadelphia/PA
    Posts
    21
    already set to oss I wanted to see if someone could post a working doomconfig file to see where I might be having a problem

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •