Find the answer to your Linux question:
Results 1 to 10 of 10
I am having a problem with every game I try playing that requires hardware acceleration. My graphics card is capable, I used to play Half Life 2 when I had ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35

    Mesa sucks.


    I am having a problem with every game I try playing that requires hardware acceleration. My graphics card is capable, I used to play Half Life 2 when I had a different operating system and it was gorgeous. Then I realize that Mesa is installed and being used. My question is this, how do I go about disabling/removing mesa, and getting the correct driver for my graphics card to support hardware acceleration? Or is there a different method to go about getting hardware acceleration to work?

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Peterborough, UK
    Posts
    379
    If you're using an NVidia graphics card, go to http://www.nvidia.com/object/unix.html to get a driver.
    \"I am, after all,\" said Pooh, \"a bear of very little brain.\"
    MY PC: Athlon XP64 3000+ on a Asus K8V-X mobo w/1GB of non-descript RAM. AGP - GeForce 2 MX400. PCI - Creative Live! 5.1 soundcard. 140 GB and 120 GB SATA WD drives.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35
    I'm using ATI.

  4. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    ATI drivers are notoriously bad for linux, you can get the linux drivers for your ATI card off of the ATI site.

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35
    Well, I installed the correct driver with no failures, however my system is still using Mesa. Here is the error message I receive when trying to play Enemy Territory.

    GL_RENDERER: Mesa GLX Indirect


    ************************************************** *********
    You are using software Mesa (no hardware acceleration)!
    Driver DLL used: libGL.so.1
    If this is intentional, add
    "+set r_allowSoftwareGL 1"
    to the command line when starting the game.
    ************************************************** *********
    ...WARNING: could not set the given mode (4)
    Initializing OpenGL display
    ...setting mode 3: 640 480
    Using XFree86-VidModeExtension Version 2.2
    XF86DGA Mouse (Version 2.0) initialized
    XFree86-VidModeExtension Activated at 640x480
    Received signal 11, exiting...


    I need a first-person shooter in my life hahaha.

  6. #6
    Linux User
    Join Date
    May 2005
    Posts
    473
    Quote Originally Posted by thanks
    I'm using ATI.
    thats your problem, i got a ati 9000 pro and it wont run anything (well i acualy got cs 1.6 working, but very laggy) go grab a nvidia 6600 there only like 100$ or even beter a 6600GT or 6800 (gt around 160-200 and 6800 180-220) i acualy like the 6600gt beter and it has reportadly gotten beter benchmarks than the 6800

  7. #7
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    Exactly which Ati card do you have?

    I have had good success with all of my Ati cards and 3d hardware acceleration using the open source drivers, but none of my cards are "high end". I gather that high end Atis and All-in-Wonders have poorer support from the open source driver.

    Depending on which card you have, it may be limited to lower resolutions if you want 3d hardware acceleration. For example, my old Ati Rage128 can display up to 2048x1536i, but if I want 3d hardware acceleration I need to use a much lower resolution (I have it set to 1024x768 for now).

    In order to get hardware acceleration working with the open source drivers, here are a couple things you may need to do:

    1. Set the video driver to "ati" and make sure DRI is enabled in your xorg.conf (or XFree86)

    2. Make sure your AGPGART module is functioning properly (assuming you're using an AGP card).
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35
    I have a 9600SE.

    I'm sorry but I am not sure how to do step #1, I've never had to configure my xorg. If I can't figure it out in google, I'll post back.

    I'm not sure what #2 even means, I apologize. An explanation would help greatly.

  9. #9
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35
    Ah I looked up configuring an xorg.config or xfree86, now I have a newbie question. How do I tell what I have? xfree86 or xorg?

  10. #10
    Just Joined!
    Join Date
    Aug 2005
    Posts
    35
    Heh, funny story. I typed ati as the driver in my xorg.conf. Yeah, that didn't work but it was sure worth a shot. My very very limited vi and command line only skills were put to the test a little earlier than I had thought. It was extremely rewarding however to fix my x11 system with no help from anyone. That probably sounds easy to most of you guys but it was a huge accomplishment for myself. I notice when trying to play some games it says that I'm using glx as my opengl acceleration. In other words Mesa indirect. How would I change that to hardware, and would it also have to do with my xorg.conf?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •