Find the answer to your Linux question:
Results 1 to 5 of 5
While using Mandrake I was able to choose which sound server to use - Alsa, OSS etc. With RH9 the only 'option' regarding sound was on installation it asked if ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305

    Sound in Red Hat 9


    While using Mandrake I was able to choose which sound server to use - Alsa, OSS etc.

    With RH9 the only 'option' regarding sound was on installation it asked if I could hear the test sound. Which I did.

    Everything was fine, apart from XMMS losing sound occassionally when Mozilla was running.

    However, the sound from my system has now deteriorated. Ogg playback is very distorted at the high frequencies. Dunno why it's happened.

    Since I can't seem to find any sound servers running on me system should I get round to adding Alsa or esound to try and sort the sound quality out?

    Thoughts?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I'm not a Redhat user, but I've had similar problems under Mandrake 9.1. I think I adjusted some of the sound settings in KDE, disabling some of the channels that the sound server tries to use. I have a funny feeling this isn't the answer though Are you using Gnome (the default) or KDE?

    I did a bit of a Google search and found this from: http://homepage.ntlworld.com/garrykn...nux/hints.html

    'The solution: There are three solutions that I know of. The simplest is to open KDE's Control Center and go to the Sound section and, on the General tab in the Sound Server section, change the 'Autosuspend if idle for' time to 1 second. This gives other apps a better chance to grab the sound card. Another possible solution is to turn the aRts daemon off altogether. In Control Center, Sound, Sound Server, on the General tab, deselect the Start aRts soundserver on KDE startup item. You'll be asked if you want to shut down the server now; just answer Yes. The third solution only works with some cards. In KDE Control Center, Sound, Sound Server, on the Sound I/O tab, select Use custom sound device and enter /dev/dsp2. This forces the aRts sound daemon to use your card's second digital signal processor, leaving the first for other applications. Remember to click 'Apply' to make the settings permanent.'

    Hope this is better than nothing
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Did you install the correct driver?

    What card do you have?
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Fingal, AFAIK I didn't install any of the KDE, just went for the default Gnome/Bluecurve install. Could be an option though.

    CopperTop, sound is an onboard i810/AC97 chip. I believe sound support is built into the kernel for this beast. Hence I didn't install any drivers.

    Ta

  6. #5
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    I think we use the same modules.

    Try to load this module: i810_audio (modprobe)

    If you get any sound after doing a "cat /dev/urandom > /dev/dsp" it worked out okay.. Redhat might have noticed the soundcard, modprobed the correct drivers etc, but plugged a sound-driver in on it like artsd. check for it like "ps aux | grep -i artsd | grep -v grep" or "lsof | grep dsp"

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •