Find the answer to your Linux question:
Results 1 to 9 of 9
I'm using suse 9.1 pro, and the sound seems to be really messed up. I've only been able to get it to work a few times, once it seemed to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    75

    Sound Issues


    I'm using suse 9.1 pro, and the sound seems to be really messed up. I've only been able to get it to work a few times, once it seemed to work fine, and the other times it skipped, almost like I was playing a scratched CD. Anyone else had the same problem, and anyone know how to fix it?

  2. #2
    Linux Engineer oldcpu's Avatar
    Join Date
    Aug 2005
    Location
    Europe
    Posts
    1,142

    Re: Sound Issues

    Quote Originally Posted by corinth
    I'm using suse 9.1 pro, and the sound seems to be really messed up. I've only been able to get it to work a few times, once it seemed to work fine, and the other times it skipped, almost like I was playing a scratched CD. Anyone else had the same problem, and anyone know how to fix it?
    I now use SuSE-9.3 pro, and I have no sound issues. Sound works reliably, and its great.

    When I used to use SuSE-9.1 pro, I did notice there were a number of older misbehaved apps, which would not release the audio driver after they were finished. Which meant that sometimes audio would not work. In those cases I either had to find the part of the app causing the problem (and sometimes kill it manually via bash shell "kill -9 app-id"), or a simple 2-minute re-install of the audio driver. .... I know, I know ... re-installing the audio driver is taking a sludge hammer to kill a fly, but it was quick to do (less than 2 minutes) and it always worked.

    I have never encountered the "scratchy" sound you mention.

  3. #3
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    hmm, I have encountered this kind of scratchy and low quality sound in SuSE 9.2, but not in 9.3. The work-around i found for 9.2 was to launch the KDE control center -> Sound and Multimedia -> Sound System -> Hardware tab. Here I selected OSS as the sound system and volia, no more scratchy, low quality sound.
    Life is complex, it has a real part and an imaginary part.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    75
    Alright, selecting OSS as the sound made it work. But now I have another problem, the sound is really soft. Any help?

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try increasing the volume on the mixer, or your speakers, or the volume control of the program you are using to play the file.
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Just Joined!
    Join Date
    Sep 2005
    Posts
    75
    Done, done, and done. Still too quiet.

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    is there good connection between speaker and sound card? I don't know if it will help, but try running alsamixer and increase the volumes there. It might help.
    Life is complex, it has a real part and an imaginary part.

  9. #8
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    I don't think alsamixer will do him much good now that he's fallen back on OSS/Free.
    Does the KDE mixer have a toggle for OSS/Alsa? If not, you should be able to get aumix or some equivalent fairly easily from Suse's repositories.
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  10. #9
    Just Joined!
    Join Date
    Sep 2005
    Posts
    75
    All fixed! I used Kmix, and I was able to raise a setting I didn't see in the others. Sound is working great now, thanks for all your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •