Find the answer to your Linux question:
Results 1 to 7 of 7
Hi! My problem in short terms: The soundcard produces (good) sound, but I cannot control the volume. The only thing I can do with alsamixer is muting the PCM-channel. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    iks
    iks is offline
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    ALSA works fine - except the volume-controls


    Hi!

    My problem in short terms: The soundcard produces (good) sound, but I cannot control the volume. The only thing I can do with alsamixer is muting the PCM-channel.

    I am using kernel 2.6.8, alsa v1.0.9a and the internal soundcard of an asus K7S41 mobo (SiS7012 (says /proc/asound/cards) - uses intel8x0-module). First I had no asound.conf-files nowhere, now there's a global dmix-conf active. Makes no difference: still no control.

    I have no ideas where to start. - You?

    thnx
    IKS

    PS: I have found some hints that this problem is linked to the mobo...

  2. #2
    iks
    iks is offline
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    go a go - but no control

    Hi again.... - I've played around with alsas softvol-plug and et voila: It doesn't work. Well - at least it refuses collaboration with the alsamixer, but it's seems to be good enough for mpd...

    So I am confused, but quite happy with the situation.

    Just in case someone has found this thread, I want to leave my conf-files here:

    /etc/asound.conf
    Code:
    pcm.!default {
        type plug
        slave.pcm "svol"
    }
    
    pcm.svol {
        type softvol
        slave.pcm "hw:0,0"
        control {
            name "Volume"
        }
    }
    (I chose 'Volume' because 'Master' or 'PCM' resulted in alsamixer-segfaults...)


    /etc/mpd.conf
    *snipp*
    Code:
    # mixer
    mixer_type              "alsa"
    mixer_device            "dmix"
    *snapp*

    According to this conf-file, the complete asound.conf-stuff is irrelevant to the solution.

    cya
    IKS[/code]

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2

    OSS emulation?

    Your .asoundrc worked perfectly for my onboard soundcard with Alsa-native programs. But, I am having problems with a program that does not support Alsa's mixer properly. I edited /proc/asound/card0/oss_mixer to map PCM to "Volume", but there is no effect on the volume of the audio. How can I fix this situation?

  4. #4
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    it seems like the program you are describing is using OSS. You need to have OSS emulation enabled for that program to produce sound. OSS produces sound from /dev/dsp so if you don't have that you need to enable OSS in your kernel or from whatever configuration utility you use.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  5. #5
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2
    I am trying to use the binary of mythtv available for fedora core 4. It accepts ALSA:default for the audio, but when i try to set the mixer, it comes up with errors. I have been trying to get it to work with OSS emulation, but I have only been able to change the value of "Volume".

    Using /dev/dsp as my audio device and /dev/mixer as my mixer, when I reduce the volume in mythtv (or xmms using the OSS drivers instead of alsa), Kmix shows that the value has been changed. But, the actual output to my speakers has not been modified in any way.

    Is there any more information I should provide? How should I go about fixing this?

  6. #6
    Just Joined!
    Join Date
    May 2006
    Posts
    1

    Question Ever got this working?

    Did you ever get this working?

  7. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    Lightbulb

    Hi!

    I had a similar problem one month ago and have spent a lot of time in its solution. As I stumbled upon this post, probably others will, so I'll post the link to a howto I wrote:

    http://alsa.opensrc.org/How_to_use_s..._master_volume

    I hope this helps someone...

    Ingo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •