Find the answer to your Linux question:
Results 1 to 2 of 2
I'm on the verge of insanity here going back and fourth seeing the same error a hundred times. Yes, i have googled it...yes, i have been to the OpenAL website ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    63

    Installing OpenAL


    I'm on the verge of insanity here going back and fourth seeing the same error a hundred times. Yes, i have googled it...yes, i have been to the OpenAL website and i haven't found crap there mentioning anything about installing...just..downloading. I've been inside the OpenAL folder and they don't really give instructions on how to install it either. And if there is, i've obviously missed it and would like to know where i could find how to install it.

    Anyways.... basically i've been trying to install OpenAL because, evidently, the one linux installs, particularly Suse 10.0, doesn't exactly work with UT2004 (since UT2004 runs horribly when i have the sound on, but once i turn it off it runs magically 10x faster).

    So these are the things i want to do in order

    1. Install OpenAL

    2. Copy "openal.so" (or libopenal.so and rename it openal.so) into /home/ME/ut2004/System/

    3. Then install a hardware accelerated version of OpenAL that i found at here
    http://www.linux-gamers.net/modules/...p?articleid=40 (look under "3. SDL and OpenAL")

    Once i get OpenAL installed, the rest shouldn't be too hard to do.




    Also, since i there is no ./configure in the openal/beos/src folder i just tried make...and whenever i try to make i get

    Code:
    Makefile:39: /boot/develop/etc/makefile-engine: No such file or directory
    make: *** No rule to make target `/boot/develop/etc/makefile-engine'.  Stop.

    EDIT:

    Thanks to loft306, i've figured out most of what my problem is. For some reason, CVS isn't getting all the files i need to install OpenAL (mainly the directory "linux" in the openal folder). So, once i figure out why the hell CVS is getting all the files i'm pretty much screwed.

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    you will have to run the
    Code:
      sh ./autogen.sh
    in /path/to/where/u/put/it/openal/linux in order to create the configure file here is the INSTALL(readme)
    If this is your first time retrieving CVS, you will need to build the
    configure script and config.h.in dependency. Just run

    sh ./autogen.sh

    and you should be okay.

    Compilation / installation goes something like this:

    ./configure --prefix=/usr/local
    make
    cd test
    [run tests]
    make install

    If you are on x86(_64) if may be wise to send your CFLAGS along to
    configure, as dependening on them, SIMD code will be activated, ie:

    CFLAGS="-march=athlon-xp" ./configure --prefix=/usr/local

    configure will detect that "-march=athlon-xp" activates MMX, SSE,
    3dNOW!, SSE-MMX and 3dNOW! extended. You can also explicitly enable a
    specific SIMD instruction set via CFLAGS, ie -mmmx activates MMX on the
    GCC compiler. Refer to its manual. Currently OpenAL only features some
    MMX code though, so other SIMD instruction set are ignored.
    On x86 (32 bit) it is advised to have nasm installed. Then it is safe
    to activate all SIMD instruction sets at compile time, as at runtime the
    detection will only activate supported SIMD routines.
    (Above example shouldn't be used as such though, as it doesn't do any
    optimization, so send more flags and/or use the optimization configure
    option.)


    configure options:
    --enable-debug Enable debugging info.
    --enable-optimization Enables optimization.

    etc... Use --help to determine the rest. Most people will be fine with
    --enable-optimization.

    Debugging options are now in the form:

    --enable-debug-blah

    in general, this will give you too much information to be useful on a
    particular topic. Use --enable-debug-maximus to get all debugging
    messages possible.

    If this is your first time installing openal, you'll probably need to
    run ldconfig.

    ATTENTION:

    The following changes have taken place that may alter the manner in
    which an installation works on your machine. Please be advised:

    - SDL is no longer required to build --- the conversion code
    has been copied into the audioconvert directory.

    If you experience any problems building or with the test code, please
    email me: jvalenzu@linuxgames.com. Thanks.

    jv.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •