Find the answer to your Linux question:
Results 1 to 6 of 6
I have tried running Warcraft II(Dos/Mac version) using Wine but it did not work. When I tried to install Wine output "Preparing to install" and got stuck there. So I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! bowens's Avatar
    Join Date
    Dec 2005
    Posts
    5

    Warcraft II with DosEmu


    I have tried running Warcraft II(Dos/Mac version) using Wine but it did not work. When I tried to install Wine output "Preparing to install" and got stuck there. So I decided to try DosEmu. The installation went fine. I ran the game. It was fine. Until I tried to start a single player game. Then it asked me to insert the cd which was in the cdrom drive. I'm still kind of a Linux newb so I'm not sure what to do to get it working. Has anyone else successfully run Warcraft II with DosEmu? Thanks in advance.

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    Can't say I have, but I would make sure that the disk was mounted before you start DosEmu, also, check out their site/mailing list, it seems possible that such a low level emulator might not support cd drives at all (in which case, copy and pasting the files is prob your best bet)
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Just Joined! bowens's Avatar
    Join Date
    Dec 2005
    Posts
    5
    I have DosEmu set up to use the cdrom. I installed WC II from cd. The game just does not recognize that the cd is there. My cdrom drive was mapped to drive E: for DosEmu. I even changed it to D: to see if that would help, since D: is most common on windows. The cdrom works fine until the game is running.

    Do you have any other suggestions on how to get WCII running on Linux. Maybe another emulator or somehow to get Wine to run it?

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nth Richmond, NSW, Australia
    Posts
    37
    were can i get this "DosEmu", if i can i will try and test it out and see what i get when i run Warcraft II.

  5. #5
    Just Joined! bowens's Avatar
    Join Date
    Dec 2005
    Posts
    5
    www.dosemu.org

    In the autoexec.bat file it says to uncomment a line to enable cdrom support. So I tried this and it said it cannot load the driver.

  6. #6
    Just Joined! bowens's Avatar
    Join Date
    Dec 2005
    Posts
    5
    Nevermind. I finally found a website that showed me what to do. I had to edit the config.sys file and the autoexec.bat. But it is working now. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •