Find the answer to your Linux question:
Results 1 to 5 of 5
hi all. i have a problem with setting up my sound card on my notebook. not again, you might think, but please bear with me. i have a intel hda ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    32

    alsa sound, getting rid of oss, how?


    hi all.
    i have a problem with setting up my sound card on my notebook. not again, you might think, but please bear with me.
    i have a intel hda card (ALC880) (3 jacks, one is a shared headphone/SPDIF jack) in my z9200va notebook.
    1. installed the new alsa 1.0.10 drivers according to their howto.
    2. boot into init 3, then manually add module "modprobe snd-hda-intel model=z71v" and there we go, the sound works perfect.
    3. boot into init 5 (xserver), and no sound.
    aah, forgot to edit the /etc/modprobe.conf he did you might think, but hang on.
    "lsmod |grep snd" gives me two different outcomes when i boot into init 3 and init 5:
    if i _didn't_ manually add the module and boot regulary (i.e. no init 3) then "lsmod|grep snd" gives a lot of oss entries (like "snd_pcm ... snd_pcm_oss,snd_hda_intel,snd_hda_codec") which do not appear if i type "modprobe snd-hda-intel model=z71v" at init 3 (above entry then reads "snd_pcm ... snd_hda_intel,snd_hda_codec").
    hmm, so my question is, how can i have normal sound after startup without having to load the module manually. and yes, i edited /etc/modprobe.conf and /etc/modprobe.d/sound accordingly, it doesnt help.
    or maybe somebody can tell me how to unload the redundant oss modules, that apparently are loaded when booting directly to the xserver,
    but don't show up when booting with init 3, manually loading the module, then typing init 5.
    i hope that all makes sense to somebody, thanks for any help.
    harris

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    32
    ok, sorry to bother again, but i fiddled around some more.
    it appears now that i can't even get the sound working with the manual method described above. no idea what i did, i just played around in the various conf files.
    even restoring the backup'ed files does not reestablish the sound. weird.
    but: even though i did not add any lines in the /etc/modprobe.conf and did not run alsaconf, there are still sound modules loaded as seen by lsmod.
    so, how and where can i possibly get rid of those modules, especially those oss modules (snd_pcm_oss,snd_mixer_oss) i want to get rid off. i don't understand
    where they come from in the first place, since i compiled the alsa driver explicitly without oss emulation.
    please help, thanks
    harris

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    first you should check your kernel and see if OSS is enabled. This somewhat varies on your distribution but you should find an easy guide by googling your distro plus changing the kernel or something like that. If it is enabled, disable it and compile kernel and then edit lilo or grub appropriately.

    then do: as root: modprobe -l

    see if any oss stuff is still there if it is manually remove.
    rm /lib/modules/whereever your stuff appears. Then restart alsa sound daemon and see if it works.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2005
    Posts
    32
    ok, i tried something different.
    i recompiled the ALSA modules with the --with-oss=no switch, and voila no more oss in my list of loaded modules. so i guess that should be alright then.
    now when i boot SuSE10.0 normally i get the opening sound (yay!), however none of the audio players produce a sound (i _did_ install all the necessary packages). the alsamixer looks like the alsamixer for the "normal" snd-hda-intel module, whereas i want it to reflect the snd-hda-intel model=z71v card (it indeed does look different for when i load the module manually it has a different look). so for some reason the sound module is loaded but without the additional model=z71v switch.
    here are the contents of the module configuration files:
    /etc/modprobe.conf has no line with snd whatsoever.
    /etc/modprobe.conf.local is empty
    /etc/modprobe.d/sound has
    alias snd-card-0 snd-hda-intel model=z71v
    alias sound-slot-0 snd-card-0
    so, maybe i put the model option in the /modprobe.d/sound file wrong? i tried leaving out model=, putting it in the next line and so on, no result...
    anybody knows how to put that straight?
    thanks, harris

  6. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    32
    hi all.
    ok, i am still stuck here with the same problem.
    maybe somebody who got his onboard (preferably notebook) soundcard working with a recent version of the ALSA drivers could post his /etc/modprobe.d/sound file contents. Also. i would be interested about the OSS_EMULATION and SEQUENCER switches in the kernel modules, are they still supposed to be set to yes (default) or did you change that?
    thanks for any help.
    harris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •