Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 31
Originally Posted by googled first sn0dig Do you now get a printout instead of an error? If yes check the printed list for this line. "direct rendering:yes" i uninstalled/installed some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Mar 2006
    Posts
    13

    Quote Originally Posted by googled first
    sn0dig
    Do you now get a printout instead of an error?
    If yes check the printed list for this line.
    "direct rendering:yes"
    i uninstalled/installed some drivers again now, and glxinfo runs fine, but it says direct rendering: No....

  2. #22
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    OK, sounds like we're at a point where we can run a couple of checks.
    Do lsmod |grep fglrx to see if the kernel module is loaded.
    Check /etc/X11/xorg.conf and see if Section "Device" has Driver "fglrx".
    Also in /etc/X11/xorg.conf, there should be a DRI section that sets permissions to 666. And the Modules section should list dri and glx to be loaded.
    Stand up and be counted as a Linux user!

  3. #23
    Just Joined!
    Join Date
    Mar 2006
    Posts
    13
    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver "nv"
    wrong driver?

  4. #24
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    In that ubuntu link in my last post they mention having to edit xorg.conf. One of the changes is removing 'nv' and replacing it with 'nvidia'. This makes sense to me. It's something that's done when installing the drivers by my method.
    Look at that thread again and read the advice for "method 1". Why not try those changes to xorg.conf , one change at a time starting with changing the 'nv' to 'nvidia' ? If they don't work you can always reverse the changes.

    btw: Don't know if those are the right drivers. Could be. Anyone here running that card?
    WARNING: I may be telling you more than I know !

  5. #25
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Wow, I really messed up my last post. I started thinking you had an ATI card, hence the references to fglrx (ATI's driver module).

    OK, so the "nv" driver is xorg's own driver and not nvidia's accelerated driver. Change xorg.conf so that the driver is "nvidia" instead.
    Also, make sure the modules section of the file is set to load glx, but NOT dri or speedo. And it looks like you don't need the DRI section that I mentioned before (that was just for ATI cards).

    There is still a chance that you'll have bad symlinks (nvidia is notorious for that), but we'll cross that bridge when we get to it. It may be that you just need to change the driver name in xorg.conf and all will be well.
    Stand up and be counted as a Linux user!

  6. #26
    Just Joined!
    Join Date
    Mar 2006
    Posts
    13
    allrightythen.. not sure what i did, but i got it working.. exept that i set the video mode to "software" instead of openGL... and now it won't start.. is there like a text file that i can change that in? like a config file where it says "Video Mode: Software"

  7. #27
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Dangit! I got curious about how that could happen, and ended up doing the same thing.

    Finding the fix took a bit of digging; luckily it ended with one episode of trial and success. Here's what you do:
    Find the file ~/.armyops250/System/ArmyOps.ini and open it in a text editor. You'll notice it's a very long file.
    Lines 19-23 show different render devices the game can use, all of which are commented out by a semicolon except for one. In my case, line 22 was not commented out, and it said RenderDevice=PixoDrv.PixoRenderDevice, which matched the line below it (except the line below was commented out).
    Starting at line 792, there's a list of render devices and options for each device. The third device, at line 848, is called OpenGLDrv.OpenGLRenderDevice, and was not in my list near the top of the file. I'm guessing it was there at first, but got replaced when I selected the software renderer.
    Copy (DO NOT CUT) the name of the OpenGL device and use it to replace the device name near the top of the file. So in my case, on line 22 I replaced RenderDevice=PixoDrv.PixoRenderDevice with RenderDevice=OpenGLDrv.OpenGLRenderDevice, and the game works normally now.
    Stand up and be counted as a Linux user!

  8. #28
    Just Joined!
    Join Date
    Mar 2006
    Posts
    13
    i don't have the ArmyOps.ini file? :S

  9. #29
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Wow, really? What's in your ~/.armyops250/System directory?
    Stand up and be counted as a Linux user!

  10. #30
    Just Joined!
    Join Date
    Mar 2006
    Posts
    13
    Quote Originally Posted by Zelmo
    Wow, really? What's in your ~/.armyops250/System directory?
    it's arrange by name, so i should think it would be right around here... http://img146.imageshack.us/img146/7...ermdump5dq.png

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •