Ok i thought i would install dark oberon,First i got this error,

Code:
lfw -lGL -lX11 -lGLU -o ../dark-oberon
/usr/bin/ld: cannot find -lglfw
collect2: ld returned 1 exit status
make[1]: *** [../dark-oberon] Error 1
Viewing the readme i see ,

Code:
You will also need to add -lfmod-3.74 to the end of LIBRARIES variable in
   src/Makefile.

   If the compilation ends with "ld: cannot find -lglfw", you don't have GLFW
   installed in you system or it was not found. If GLFW is not in your system
   and there is no installation package, compile it yourself and put libglfw.a   into libs/ subdirectory. If it was not found, specify path to libglfw.a in
   src/Makefile (variable LIBPATH) or copy it into libs/ subdirectory.

   If you had any troubles with compiling, tell us on our Help forum. The link   for the forum can be found at our homepage.
I am useing the nvidia drivers that are configured correctly so i dont no why i would need GLFW framwork ,Any way i compiled it and i still get the same error.