Find the answer to your Linux question:
Results 1 to 7 of 7
As a relative newbie to Linux, I've noticed that within the distro's I use, the overall volume output from the built in drivers is a lot lower than that when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Norfolk, UK
    Posts
    49

    Audio volume in Linux


    As a relative newbie to Linux, I've noticed that within the distro's I use, the overall volume output from the built in drivers is a lot lower than that when I've used the Creative or Windows drivers within Windows XP. Also the sound quality is dramitically lower, and even distorts at moderate levels.

    I imagine this is a driver problem, and is not splitting the signal correctly to the subwoofer/satellites, and not boosting the signal as much as in Windows? Has anybody experienced this difference?

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Yup. It's a bit difficult to perfect the drivers if the manufacturer doesn't help.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Location
    .nl
    Posts
    70
    yup, not only that .. I've found a 'solution' for it as well (for Arch anyway).

    I have the Alsa drivers installed and used "alsamixer' to maximize the volume. I had to do that because the volume output was too low otherwise. Disabled OSS probing in "modprobe.conf" and installed some plugins for xmms and xine to improve overall quality. It's a lot better now

    Cheers,

    Rob

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Quote Originally Posted by Infinity
    Disabled OSS probing in "modprobe.conf"
    Can you explain this further? I'm really intrigued. What kind of lines need to be changed in that file? Do you just comment them out, or specify that certain aliases are to be turned off?
    Stand up and be counted as a Linux user!

  6. #5
    Just Joined!
    Join Date
    Jul 2005
    Location
    .nl
    Posts
    70
    Quote Originally Posted by Zelmo
    Can you explain this further? I'm really intrigued. What kind of lines need to be changed in that file? Do you just comment them out, or specify that certain aliases are to be turned off?
    Sure

    Comment out the OSS lines and I also had to disable the second alias, like so:

    Code:
    #
    # /etc/modprobe.conf (for v2.6 kernels)
    #
    
    # OSS Compatibility
    #install snd-pcm modprobe -i snd-pcm ; true
    #install snd-seq modprobe -i snd-seq ; true
    
    # --- BEGIN: Generated by ALSACONF, do not edit. ---
    # --- ALSACONF version 1.0.10 ---
    alias snd-card-0 snd-cmipci
    #alias sound-slot-0 snd-cmipci
    # --- END: Generated by ALSACONF, do not edit. ---
    I still have OSS though, through alsa (pacman -S alsa-oss)
    My hardware specs aren't great, not at all actually.Still, my music sounds amazing Hooray for Arch !

  7. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    AFAIK, those lines were for alsa-oss, not the real OSS, and just removed because udev got some module autoloading.

    Start a mixer, like alsamixer or the graphical for your DE. Make sure that both PCM and Master have sane settings, the volume control only control one of them, but both control the output to the soundcard. Make sure none of them is turned to the highest possible setting though, as it (at least on my soundcard) make some low, summing noise.

  8. #7
    Just Joined! nulio's Avatar
    Join Date
    Mar 2006
    Posts
    5
    Quote Originally Posted by jaboua
    AFAIK, those lines were for alsa-oss, not the real OSS, and just removed because udev got some module autoloading.

    Start a mixer, like alsamixer or the graphical for your DE. Make sure that both PCM and Master have sane settings, the volume control only control one of them, but both control the output to the soundcard. Make sure none of them is turned to the highest possible setting though, as it (at least on my soundcard) make some low, summing noise.
    I noticed that the lowest the pcm volume, the better is the sound quality. But i've got a problem here, everytime amaroK starts playing a new song, pcm goes back to 100%. Is there a way to correct that? I use SuSe 10.0 64 bit, and my mobo is A8N-SLI Deluxe.

    Thanks for the help.

    And sorry for my poor english

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •