Find the answer to your Linux question:
Results 1 to 7 of 7
ok i just installed fedora 5. now im trying to get mplayer to work on my machine but the gcc verion is too high and when i compiled it all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3

    Mplayer Installation Help


    ok i just installed fedora 5. now im trying to get mplayer to work on my machine but the gcc verion is too high and when i compiled it all sorts of errors popped out. so i download gcc-3.4.4-3.I686.rpm. when i tried to install it with rpm -ihv an error popped out: failed dependencies cpp = 3.4.4-3 needed.

    i've looked everywhere for cpp ver 3.4.4-3 to no avail. is there a easier way to install mplayer or does anyone know where i can download cpp-3.4.4-3? any help would be appreciated thank you.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    if you are going to use the rpm of gcc, why don't you just install the rpm of mplayer?
    http://bordeaux.freshrpms.net/rpm.html?id=953
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    when i tried to install it, i was missing like 15 dependencies. is there a way i can use yum to install it? or how can i configure yum to use freshrpms.net as a repository? thanx

  4. $spacer_open
    $spacer_close
  5. #4

  6. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    thx for the help installing mplayer vergil83. but now i got a new problem. mplayer works fine for mp3s but when i try to play an .avi file it gives me the following error:

    MPlayer dev-CVS--4.1.0 (C) 2000-2006 MPlayer Team
    CPU: Intel Pentium 4/Celeron 4 Northwood; Pentium 4 EE/Xeon Prestonia,Gallatin (Family: 15, Stepping: 4)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support.
    You will not be able to use your remote control.
    Playing test.avi.
    AVI file format detected.
    VIDEO: [XVID] 704x384 16bpp 23.976 fps 869.3 kbps (106.1 kbyte/s)
    ================================================== ========================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 48000 Hz, 2 ch, s16le, 160.0 kbit/10.42% (ratio: 20000->192000)
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    ================================================== ========================
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ================================================== ========================
    AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 704 x 384 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.83:1 - prescaling to correct movie aspect.
    VO: [xv] 704x384 => 704x384 Planar YV12
    X11 error: BadAlloc (insufficient resources for operation)?,?% 1 0


    MPlayer interrupted by signal 6 in module: vo_check_events
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
    gcc version. If you think it's MPlayer's fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
    won't help unless you provide this information when reporting a possible bug.

    any idea whats wrong with it? im think it's got something to do with the graphics thing. because mp3 files work fine. just anything having to do with graphical display such as avi files or dvds it displays this error. thx in advance

  7. #6
    hai
    hai is offline
    Just Joined!
    Join Date
    Apr 2006
    Posts
    16
    Missing Dependency: libmp3lame.so.0 is needed by package mplayer

    where can I find this file ,have any body help me thanks

  8. #7
    hai
    hai is offline
    Just Joined!
    Join Date
    Apr 2006
    Posts
    16
    after I install mplayer_fonts I install mplayer but it still say that
    Missing Dependency: mplayer-fonts is needed by package mplayer
    I don't know what to do
    have any body tell me why

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •