Find the answer to your Linux question:
Results 1 to 3 of 3
I have a problem with my matroska file, converted from an avi file. The sound in the avi file is fine, however there is no sound in matroska. It was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    6

    Matroska, no audio


    I have a problem with my matroska file, converted from an avi file. The sound in the avi file is fine, however there is no sound in matroska. It was working previously on another file, but I do not know having anything changed. I have tried to play it with different players, all play the video fine, but no audio at all.
    When I look at the streaming info in xine, it reads:
    Audio:
    has: yes
    handled: yes
    ignore: no
    codec: unavailable
    fourcc: 0x0
    channel: 0
    bitrate: 0
    bits: 0
    samplerate: 0

    vlc streaming info reads:
    codec: mpga
    language: francais
    type: audio
    channels: 2
    sample rate: 44100 Hz

    mplayer says:
    [mkv] Track ID 1: video (V_MS/VFW/FOURCC), -vid 0
    [mkv] Track ID 2: audio (A_MPEG/L3), -aid 0, -alang fre
    [mkv] Track ID 3: audio (A_MPEG/L3), -aid 1, -alang ger
    [mkv] Will play video track 1
    [mkv] Will play audio track 2
    Matroska file format detected.
    VIDEO: [DIVX] 768x432 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
    ================================================== ========================
    Trying to force audio codec driver family libmad...
    Opening audio decoder: [libmad] libmad mpeg audio decoder

    Too many video packets in the buffer: (1474 in 8422941 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    Cannot sync MAD frame
    ADecoder init failed
    ADecoder init failed
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3

    Too many video packets in the buffer: (1474 in 8422941 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    ADecoder init failed
    ADecoder init failed
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

    Too many video packets in the buffer: (1474 in 8422941 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
    Selected audio codec: [ffmp3] afm: ffmpeg (FFmpeg MPEG layer-3 audio decoder)
    ================================================== ========================
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ================================================== ========================
    alsa-init: 1 soundcard found, using: default
    alsa: 44100 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
    AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 768 x 432 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [x11] 768x432 => 768x432 Planar YV12
    SwScaler: using unscaled Planar YV12 -> BGRA special converter

    Here is an excerpt of mkvinfo:
    A track
    | + Track number: 2
    | + Track UID: 2381057695
    | + Track type: audio
    | + Enabled: 1
    | + Default flag: 1
    | + Forced flag: 0
    | + Lacing flag: 1
    | + MinCache: 0
    | + Timecode scale: 1.000000
    | + Max BlockAddition ID: 0
    | + Codec ID: A_MPEG/L3
    | + Codec decode all: 1
    | + Default duration: 26.122ms (38.281 fps for a video track)
    | + Language: fre
    | + Audio track
    | + Sampling frequency: 44100.000000
    | + Channels: 2
    | + A track
    | + Track number: 3
    | + Track UID: 1118514082
    | + Track type: audio
    | + Enabled: 1
    | + Default flag: 0
    | + Forced flag: 0
    | + Lacing flag: 1
    | + MinCache: 0
    | + Timecode scale: 1.000000
    | + Max BlockAddition ID: 0
    | + Codec ID: A_MPEG/L3
    | + Codec decode all: 1
    | + Default duration: 26.122ms (38.281 fps for a video track)
    | + Language: ger
    | + Audio track
    | + Sampling frequency: 44100.000000
    | + Channels: 2

    Any help is appreciated!!

    Cheers,

    Ahab

  2. #2
    Just Joined!
    Join Date
    Mar 2006
    Posts
    6
    Hi again,
    I tried to extract the audio from the matroska file-it is empty! I used mmg to convert the avi to mkv, and
    mkvextract tracks test.mkv 2:french
    to extract the mp3 file-it has 0 MB! I tried to extract it directly from the avi using:
    mkvextract tracks test.avi 2:french.mp3
    here the answer:
    (mkvextract) No segment/level 0 element found.
    progress: 100%
    any idea? It worked the other day so there seems to be a problem. But not even re-installation fixes the problem
    Cheers,

    ahab

  3. #3
    Just Joined! samurailink3's Avatar
    Join Date
    Oct 2006
    Location
    US
    Posts
    28
    I'm having the same problem with an mkv file. Any ideas? Used VLC, totem (with added codecs), Mplayer.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •