Find the answer to your Linux question:
Results 1 to 4 of 4
I've been trying to get a little mp3 box going after reading the how-to on TDLP, but I'm taking it one step at a time so that I can deal ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602

    Sound issue after kernel recompile


    I've been trying to get a little mp3 box going after reading the how-to on TDLP, but I'm taking it one step at a time so that I can deal with issues one at a time. What I've done so far is install Slackware 10.2 (very basic install, w/ just the required software/libraries) and configured the sound. It works pretty well in it's current state. So I decided that to get a little faster boot up I should recompile the kernel without any modules (I've recompiled a kernel a few times, no issues there).

    Everything worked the way it should except sound! Sound does work, the problem is that it's extremely low, and because I compile the kernel with no modules ALSA doesn't work. Can anyone shed some light? I'd really like to keep the kernel without any modules for a few reasons (bootup speed, simplicity, etc).

    Thanks

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    I'm not a kernel expert, but it sounds to me like (obviously) you're missing the sound kernel module, therefore sound doesn't work. Did your performance really increase that significantly when you recompiled the kernel? If not, I'd suggest just going back to what works and use the default kernel.

    If you're just looking to boost boot speed, disabling services you don't need can help a lot. For instance, if you're not using the CUPS printer daemon or your ethernet connection, disable CUPS and eth0. Just a thought.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Alsa doesn't work very well when compiled static.

    Just compile it as a module.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    I just want to clarify something, sound does work, it's just a very low volume! I have to crank the speakers up to be able to listen to songs at the same level as before.

    Quote Originally Posted by techieMoe
    Did your performance really increase that significantly when you recompiled the kernel? If not, I'd suggest just going back to what works and use the default kernel.

    If you're just looking to boost boot speed, disabling services you don't need can help a lot.
    Boot up speed did increase (I haven't timed it, but I'd say about 5 seconds on a system that boots in about 30 sec... in % that's quite a bit), specially since I disabled every possible driver from the kernel (agpgart, all fs's except ext2/3, etc). I already have all unneeded services disable, including hotplug. With the regular Slack kernel it's already pretty fast, but I wanted it a little faster (it takes a little time to get ALSA up and running, as well as some other stuff, that's why I recompiled without modules).

    Quote Originally Posted by antidrugue
    Alsa doesn't work very well when compiled static.
    That sucks!

    Thank for the help! Let me know if there's anything else I can do.

    The reason I want to try as much as possible to stay out of modules is because I want to be able to have the root fs in a ramdisk and disk space will be scarse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •