Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
beware that if your wmv has DRM, they can't be played in Linux...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064

    beware that if your wmv has DRM, they can't be played in Linux
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  2. #12
    Just Joined!
    Join Date
    Feb 2006
    Posts
    18
    Quote Originally Posted by Mariano
    Hi,

    To play .wmv .asf, etc in Xine you only have to download windows codecs from
    http://www.mplayerhq.hu/homepage/design7/dload.html
    to folder /usr/lib/win32 (default for Xine). If you don't have this folder, create it an then put in it all files of "essential codecs package". This only package is enough.

    Regards
    Just wanted to say that that worked a charm for me. Thanks man!

    I put the codec files in /usr/lib/codecs/ though as that's what I found the xine default to be. I could have changed the xine settings I guess but I decided not to.

    In case anyone wants to know, the xine settings are in Settings -> Decoder

  3. #13
    Just Joined!
    Join Date
    Jan 2007
    Posts
    26

    Play all video file formats in SUSE 10.1

    All video players in SUSE 10.1 depend mainly on Xine library. but due to legal constrains SUSE 10.1 uses very limeted feautures of Xine library which causes all vedio players not be able to play most video file formats
    to overcome this problem you need to do the following
    1- install the latest Xine library : open this link www.xinehq.de/index.php/releases and download the latest Xine Lib
    2- login as root
    3- unpack the tarball, use: tar xfvz tarballname.tar.gz
    4- cd to the extracted folder and
    ./configure
    make install
    5- to get the latest codecs for all video file formats you need to install the Binary Codec Packages from MPlayer site : open this link www.mplayerhq.hu/design7/dload.html
    6- unpack the tarball use: tar -xvf essential-20061022.tar.bz2
    7- cd to the extracted folder and: chmod 755 ./*
    8- copy all the folder contents to the folder that Xine uses to get codecs use: cp ./* /usr/lib/win32/
    that is all
    try to use any video program and see
    note : I don't know any legal information so you are responsible for any legal consequences

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    4
    Hi,

    I have found this rather old thread on my quest for a way to playback wmv on Linux. I am using openSUSE 10.1 64 bit.

    I have installed xine-lib-1.1.4 and xine-ui-0.99.4 (both from source), following the instructions from the xine web site. I have also downloaded the "essential" mplayer plugins and put them both in /usr/lib/codecs and /usr/lib/win32. Reading and executing these files is allowed for all user privilege levels.

    Totem still says it doesn't have a plugin to decode my wmv files. The about box says it's based on GStreamer. I tried to compile the latst GStreamer stuff, but it complained that some other lib was missing. So I got the Totem source code (v2.17.92) to create a xine based version. When I ran ./configure I was told I would have to install the xine development libraries:

    "checking for backend libraries... configure: error: you need the GStreamer or the xine-lib development packages installed"

    What else can I do but install and compile the xine lib?

    Calling xine directly results in the following error message:

    "Cannot open display 'nknown flag "%s"' for video. Falling back to primary display"

    Followed by a message

    "memory access violation" (or so, translated from German)

    I am using the latest ATI drivers (21 feb or so) on a Radeon X800 XT PE. 3D apps run fine (OpenGL).

    xine-check tells me a lot of things that are supposedly out of order with my X version etc. I have X11R6. Is there a newer version for openSUSE 10.1? I couldn't find any.

    What do I have to do to get this to work?

    Btw, I don't even know where my path is set. There is no file ~/.bash_config on my system. I have to admit that I am Linux noob. I know how to compile stuff and so (I'm a programmer), but I do not know much about Linux.

  6. #15
    Just Joined!
    Join Date
    Feb 2007
    Posts
    30

    KPlayer

    For streaming I recommend KPlayer, for me it always plays audio and video over the net quite smoothly. It uses MPlayer behind the scenes and adds a nice interface and a multimedia library on top of it.

  7. #16
    Just Joined!
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    4
    I have installed mplayer (got the source code and compiled it), but I don't know what to do so that it gets used for streaming video. When I tried to compile the mplayer ui, I got a compiler error:

    Gui/libgui.a(interface.o): In function `guiInit':
    interface.c.text+0xa67): undefined reference to `vo_setwindow'
    collect2: ld returned 1 exit status
    make: *** [mplayer] Fehler 1
    Last edited by devils casper; 03-09-2007 at 08:22 AM.

  8. #17
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    stop complaining. we are here to help you but you should ask in proper way. if you couldn't sort out SuSe's problems for last one year, you must be doing something terribly wrong.
    i suggest you to start a new thread. everyone is ready to help you out.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •