Find the answer to your Linux question:
Results 1 to 8 of 8
Hi evry1. Jus got a Trust 514DX 5.1 sound card, it's REALLY good in windows! But not so suitabnlte in Linux. I installed the card in Linux, and it went ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790

    5.1 sound doesn't work


    Hi evry1. Jus got a Trust 514DX 5.1 sound card, it's REALLY good in windows! But not so suitabnlte in Linux. I installed the card in Linux, and it went on fine, but then i realised that when i play sound, very little/nothing comes out of the sub woofer on me speakers, now i know the speakers are wired up fine as the speakers work perfectly ok in Windows. A mate of mine suggested installing ALSAGUIMixer instead of KaMix, but setting ALL settings in there STILL does not provide ANY bass at all. Has anyone out there had a similar problem and managed to solve it?!

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    What kernel version and what sound driver are you using? I run ALSA and in alsamixergui, I have the ability to adjust my bass.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    I'm using Kernel version:
    Linux linux 2.4.21-166-athlon #1 Thu Dec 18 18:24:05 UTC 2003 i686 athlon i386 GNU/Linux

    and the sound card is CMI8738/C3DX PCI Audio Device

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    ive had a soundcard of taht chipset working, try a newer kernel (and it will include a newer version of alsa), mayeb that will fix it.

  6. #5
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Have tried updating the kernel, downloaded a complete version, extracted the tarball, and run
    make menuconfig and this error:
    make[2]: *** [scripts/lxdialog/checklist.o] Error 1
    make[1]: *** [menuconfig] Error 2
    make: *** [menuconfig] Error 2
    a mate suggeted this is bcoz ncurses is not installed, so went to YaST2, it is installed. He suggested running make xconfig, and i get this error:
    make[1]: *** [scripts/kconfig/.tmp_qtcheck] Error 1
    make: *** [xconfig] Error 2
    He thought qt wasn't installed, it is! Now both of us are dried out on ideas as to why it's not workin! Anyone else had this prob and got over it? Or got any ideas about how to get round it?

  7. #6
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    does make config work?

  8. #7
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    i think that kernel config thing has been sorted in another post.

  9. #8
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Yes Make config did work thanx!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •