Find the answer to your Linux question:
Results 1 to 8 of 8
hi, i recently installed d2 with wine and have been trying to get it to run for 2 days now! this is the only game i really play so it's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    11

    Diablo 2 in wine, it's installed but won't run.


    hi, i recently installed d2 with wine and have been trying to get it to run for 2 days now! this is the only game i really play so it's driving me nuts. i've got my winecfg pointing to the mounted image and have also tried the disc to run the game, but it won't run. please i need some help! i think some of my mules are about to expire also lol.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    I had no problem installing and playing Diablo 2 with those instructions :
    http://frankscorner.org/index.php?p=diablo2
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    11
    finally, it works! thanks a lot...now to get bnet working. im new to linux so im not sure i understand how to use the script thing. i made a text file named diablo.sh copy/pasted the info, launched it, then wine failed with an error.

    this is the what happens when i run diablo.sh

    wine: could not load L"c:\\windows\\system32\\Game.exe": Module not found
    mv: cannot stat `Game.exe': No such file or directory
    mv: cannot stat `Game1.exe': No such file or directory
    root@box:/home/apoptosis/Desktop# Wine failed with return code 126

  4. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    11
    ok im using this script http://www.poksi.org/~hifi/lnxd2load...der-current.sh now but im having issues, i've changed my path but i get this error when using it

    Linux D2Loader v0.02b by hifi (Toni Spets)

    Changing directory to /root/home/apoptosis/games/Diablo II... failed!
    Check your Diablo 2 path!

    thats where d2 is located though so im confused.

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Did you follow all the instructions? Downloading the patch, download the .exe from megagames.com, making a script to launch it?

    Again, if you follow this, you should be ok :
    http://frankscorner.org/index.php?p=diablo2
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    11
    thanks for the help, i tried it again but i still get an error. i made the diablo.sh put it in my d2 directory, launched it in the terminal and i get this:

    root@box:/home/apoptosis/games/Diablo II# sh diablo.sh
    Invoking /usr/lib/wine/wine.bin Game.exe ...
    wine: creating configuration directory '/root/.wine'...
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    fixme:midi:OSS_MidiInit Synthesizer support MIDI in. Not supported yet (please report)
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    root@box:/home/apoptosis/games/Diablo II# err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:wglrocess_attach X11DRV not loaded. Cannot create default context.
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    wine: '/root/.wine' created successfully.
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    err:imagelist:ImageList_ReplaceIcon no color!
    fixme:midi:OSS_MidiInit Synthesizer support MIDI in. Not supported yet (please report)
    fixme:aspi:ASPI_ExecScsiCmd Failed
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 1\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 2\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 3\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 4\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 5\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 0\Scsi Bus 0\Target Id 6\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 0\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 2\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 3\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 4\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 5\Logical Unit Id 0
    err:aspi:SCSI_GetDeviceName Could not open HKLM\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1\Scsi Bus 0\Target Id 6\Logical Unit Id 0
    fixme:ole:ITypeInfo_fnRelease destroy child objects
    Wine failed with return code 1

    single player works fine though.
    EDIT: forgot to mention i installed the patch and forgot to mention i have the Game_crack.exe

  7. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Are you trying to run this as root?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #8
    Just Joined!
    Join Date
    Jun 2006
    Posts
    11
    yea, i didn't know you couldn't be root and do that lol, it works now. thanks for the help : ) im new to linux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •