Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm running on mandrake 10 rc1, with the lastest NVIDIA's driver installed (i owe a geforce 4 ti 4200) and the lastest Xfree86 version. When I try to compile ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    4

    Problem with liGL.la


    Hi,
    I'm running on mandrake 10 rc1, with the lastest NVIDIA's driver installed (i owe a geforce 4 ti 4200) and the lastest Xfree86 version. When I try to compile applications that need libGL.la , iI've got an error, saying that this file is not valid. I tried to install mesa but it made Xfree unable to launch. What can I do in order to have a valid libGL file?

    Thanks in advance

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284

    Re: Problem with liGL.la

    Quote Originally Posted by Atifear
    Hi,
    I'm running on mandrake 10 rc1, with the lastest NVIDIA's driver installed (i owe a geforce 4 ti 4200) and the lastest Xfree86 version. When I try to compile applications that need libGL.la , iI've got an error, saying that this file is not valid. I tried to install mesa but it made Xfree unable to launch. What can I do in order to have a valid libGL file?

    Thanks in advance
    libGL.la is provided by mesa, so the only thing i can suggest is retry the installation of the mesa package. Ensure your are installing the latest version of mesa as well, and also consider upgrading Xfree86 if your not running the latest version.

    Jason

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    4

    Re: Problem with liGL.la

    Quote Originally Posted by jasonlambert
    Quote Originally Posted by Atifear
    Hi,
    I'm running on mandrake 10 rc1, with the lastest NVIDIA's driver installed (i owe a geforce 4 ti 4200) and the lastest Xfree86 version. When I try to compile applications that need libGL.la , iI've got an error, saying that this file is not valid. I tried to install mesa but it made Xfree unable to launch. What can I do in order to have a valid libGL file?

    Thanks in advance
    libGL.la is provided by mesa, so the only thing i can suggest is retry the installation of the mesa package. Ensure your are installing the latest version of mesa as well, and also consider upgrading Xfree86 if your not running the latest version.

    Jason
    That's what I diid, but glx couldn't load. I used the lastests versions of XFree and mesa..

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    any error messages?

  6. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    4
    Quote Originally Posted by jasonlambert
    any error messages?
    No I haven't seen anything, X just quit when it had to load glx. I think that the NVIDIA's driver have specials libGL files, I was told that mesa can't be installed with NVIDIAs drivers. Is there any way to compile programs witch need those files with this driver installed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •