Find the answer to your Linux question:
Results 1 to 3 of 3

Thread: RuneScape

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1


    I play a java-based massive multiplayer online role-playing game called RuneScape, and it works fine except for a single thing: I cannot enter special characters such as apostrophes or accented characters into the game. To quote myself in a thread I posted on a RuneScape fansite (red text are clarifications):
    To cut to the chase, RS [RuneScape] does not accept any nonstandard characters when I'm using Linux. I sent a message to Jagex [Creators of RuneScape], and they simply said they didn't understand my query. Below is the message I sent them:
    RuneScape does not accept ANY special character (at least not those involving metamaps, deadkeys or composition) I feed it using Linux. This includes, but is not limited to, apostrophes, backticks and other characters such as , , , but also ć, etcetera. I know this isn't related to java since applets I've written myself do accept these characters (save for the apostrophe, which is a known javax.swing bug). The applet does recognise that I am entering a deadkey, but does not produce a character when I finish the sequence (EG, pressing ' + a does not produce , nor does it produce a regular a, thus making me conclude that it indeed recognises the apostrophe as a deadkey).

    Switching my character map to International Eliminate Deadkeys is of no avail - while it allows me to enter a normal apostrophe into other applets (using standard awt or swing input widgets), RS does not print anything.

    Furthermore, entering of special characters works fine under Windows.

    Please tell me if there is anything I can do to fix it as I find it extremely annoying.

    Thank you for your time,

    A Linux-loving customer.
    Some system stats:
    uname -r
    java -version
    java version "1.5.0_06"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
    Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)
    firefox --version
    Mozilla Firefox 1.0.8, Copyright (c) 1998 - 2005
    mozilla --version
    Mozilla 1.7.13, Copyright (c) 2003-2004, build 2006050116
    My operating system is Fedora Core 4. As I told Jagex, if there is anything on my end that can be done about it, please do tell me. If not, I'll just send in a bug report or something.
    I have also tried with the latest JDK, 1.6.0 (beta), and it allows me to enter deadkey apostrophes into regular swing applets, but it has no effect for RuneScape. Minefield (Firefox nightly) did not change anything either, as was to be expected.

    Since the people at the RuneScape fansite I posted this at generally have little expertise in Linux, I thought I'd post this here. If I can't get this fixed even with the help of you guys here, I suppose I will just submit a bug report to Jagex, but I want to be certain that it's no problem on my end first.

    Oh, and if you play RuneScape too and want to chat in-game, drop me a Private Message here .

  2. #2
    Just Joined!
    Join Date
    Nov 2005
    Auburn, Maine
    Strange... I would go ahead and send in the bug report. Runescape runs on a Linux server so I don't see why it would have anything to do with you running linux instead of windows. But you said that it works under windows so I dont know what to tell you. I dont see why they couldnt understand the message you sent to them.. *shrugs shoulders* I suppose you can either 1) Play on windows, 2) Stop using those special characters or 3) Send in the bug report. I'd do the second option if I were you, but im not so its up to you. Good luck

  3. #3
    Just Joined! Alex Stan's Avatar
    Join Date
    Aug 2006
    Hamilton, Ontario

    I've made Runescape work on FC5, using

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts