Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I'm new to Linux. Just recently installed Mandrake 9.2. It recognizes my card and says the driver snd-enuk10k is correct, but I have no sound. My speakers require a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    5

    No sound with sblive card in Mandrake


    Hello, I'm new to Linux. Just recently installed Mandrake 9.2. It recognizes my card and says the driver snd-enuk10k is correct, but I have no sound. My speakers require a digital output, and they worked with the windows system I just got rid of. Any ideas, I've made sure the volume levels aren't muted and turned up. Thanks!

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    What information does "lsmod" gives you? Is there a module called "emu10k1" there? If not, try to "modprobe" it.

    Good luck

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    5
    I am assuming when you are talking about trying "lsmod" and "modprobe" that it is done in a terminal right? Well I tried that and it says command not found. I am not exactly sure what to do.

  4. #4
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u need to be root for them to work.

    go back to the terminal, type su, then give it ur root pw. now try the commands again.

  5. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    5
    Hey guys, thanks for the help so far. I did the modprobe with root, and snd-emu10k1 is listed for several things for my sound card. In fact I discovered that if I plug a set of headphones into the back that the work! I guess I need to figure out how to turn the digital out signal on instead of the analog out. Any suggestions? Thanks.

  6. #6
    Just Joined!
    Join Date
    Feb 2004
    Posts
    5
    No worries, I figured it out. Just in case someone else is having the same problem... my soundcard was an oem Gateway sblive! not a retail sblive! and there is a difference. Apparently the ALSA drivers don't work quite as well with the OEM Gateway. In order to get a digital out signal to work with this card the old OSS emu10k1 driver must be used, and and the emu-config tools must be downloaded. Once the tools are installed you have to go to a terminal and type in "emu-config -d" to turn on the digital out, and "emu-config -a" turns analog back on. Hope that helps somebody. Later

  7. #7
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4
    I do the emu-config and it returns SOUND_MIXER_PRIVATE3: Input/output error do you know what this means? Thanks

  8. #8
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2
    has anyone figured out this problem yet?
    I also receive the SOUND_MIXER_PRIVATE3: Input/output error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •