Find the answer to your Linux question:
Results 1 to 2 of 2
Hello all, I'm having a problem with setting up my webcam. /dev/video gives me a no space on device left when I run gqcam or just cat on /dev/video. dmesg ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    webcam logitech chat (spca5xx.c) no space on device


    Hello all,

    I'm having a problem with setting up my webcam.

    /dev/video gives me a no space on device left when I run gqcam or just cat on /dev/video.

    dmesg outputs this as it should : (I tried already 4 different USB ports)

    [ 5153.914292] usb 1-10: USB disconnect, address 5
    [ 5153.914301] ohci_hcd 0000:00:02.0: leak ed ffff81007e4e53c0 (#81) state 2
    [ 5155.702979] usb 1-7: new full speed USB device using ohci_hcd and address 6
    [ 5155.813946] /usr/bin/spca5xx-20060501/drivers/usb/spca5xx.c: USB SPCA5XX camera found.Logitech QuickCam chat (SPCA561A)
    [ 5155.813952] /usr/bin/spca5xx-20060501/drivers/usb/spca5xx.c: [spca5xx_probe:5480] Camera type S561
    [ 5155.821410] /usr/bin/spca5xx-20060501/drivers/usb/spca5xx.c: [spca5xx_getcapability:1765] maxw 352 maxh 288 minw 160 minh 120



    anybody any idea how I could set this up ?

    thanks in advance ...

  2. #2
    Just Joined! vodunvibe's Avatar
    Join Date
    Aug 2006
    Posts
    2

    Howto Fix the “No space left on device” error message and Install the Spca5xx driver

    Hi,

    When other USB devices are present on the same host controller bus as the camera, the bandwidth requirements of the spca5xx driver are not being met, with some hardware configurations.
    The spca5xx driver is asking for more bandwidth than is available which results in the following error messages:

    No space left on device
    can't open /dev/video0: No space left on device.

    Please take a look at this howto. I hope that it helps you resolve your issues.
    http://www.ubuntuforums.org/showthread.php?t=247646

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •