Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
My Problem : trying to get a Pinnacle PCTV Stereo tv tuner card (for PAL BELGIUM) to work under linux Details: I'm trying to build my pvr system with mythtv. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4

    Pinnacle PCTV Stereo (saa7134) not (quite) running


    My Problem : trying to get a Pinnacle PCTV Stereo tv tuner card (for PAL BELGIUM) to work under linux

    Details: I'm trying to build my pvr system with mythtv. But first is thing to get my hardware running. The only problem I can't solve myself is the tv card setup. To test things simply I started with xawtv and tvtime. tvtime gave me info about VideoOverlay to be used instead of OpenGLOverlay in my XFree86 config. After changing this tvtime runs but gives me a blue screen with a No Signal message.I ran tvtime-scanner and I actually got sound from a channel on tvtime,but no picture, so that did seem to indicate that I must be on the right track (alas sound had 'magically disappeared' on next boot)

    Anyway here is some info about my setup :
    lsmod reports the following:
    Code:
    tda9887                 3168   1  (autoclean)
    tuner                  13128   1  (autoclean)
    saa7134                70724   0  (autoclean)
    tvaudio                14408   0  (unused)
    video-buf              13328   0  (autoclean) [saa7134]
    i2c-core               13924   0  (autoclean) [tda9887 tuner saa7134 tvaudio]
    ir-common               2500   0  (autoclean) [saa7134]
    ...
    /dev/video0 seems to be okawtv -hwscan reports the following :
    Code:
    port 59-59
        type : Xvideo, image scaler
        name : ATI Radeon Video Overlay
    
    /dev/video0: OK                         [ -device /dev/video0 ]
        type : v4l2
        name : Pinnacle PCTV Stereo (saa7134)
        flags: overlay capture tuner
    Concerned Hardware :
    -Creative labs Audigy 2 ZS
    -Ati Radeon 9700 PRO (Ati Display 3.07 + 1.3 Mesa 4.0.4 Drivers)
    -Pinnacle PCTV Stereo (Philips saa7134 chip, at first I was mislead because other Pinnacle PCTV cards use bt878 chips, but saa7134 is what it says on my chip).

    PAL B/G --> Belgium : I believe that frequencies are the same as standard Western-europe
    3 first and last channels for Belgium are :
    Code:
    E2 48.25 NOS 1 Stereo
    E3 55.25 KETNET-CANVAS Stereo Nicam
    E4 62.25 RTBF LA UNE Stereo Nicam
    ...
    E23 487.25 CARTOON NETWORK / TCM Stereo Nicam
    E24 495.25 TRT Mono
    E25 503.25 RTM Mono
    Distro : Debian unstable (sid) from Knoppix hd-install
    Kernel 2.4.24 : recompiled with alsa, v4l2, saa7134 support after patching with patch-2.4.24-rc1-kraxel (from bytesex.org)
    Installed saa7134 0.2.9 drivers (from bytesex.org) with insmod options card=26 tuner=33

    Other details: all the hardware runs fine on the same machine under Win XP Pro, so I'm not considering broken hardware.

    Any pointers are welcome, being new to linux I might of forgotten something major.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I was recently having similar trouble setting up my sister's Pinnacle PCTV card. Tell me, how new is this card? If you look at the card, does it resemble anyone of these?
    http://www.dolda2000.com/~fredrik/lf/tv-kort.jpg (my sister's card)
    http://www.dolda2000.com/~fredrik/lf/tv-kort-2.jpg (my card - almost 3 yrs old)

    Also, what kernel version are you using? I saw that it was the v4l2 driver, so I'm guessing that it's either a 2.6 kernel, or you've patched a 2.4 one. Could you also attach the output of lspci?

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    My card looks like your sister's (bought it new a few weeks ago) as regards to the metal plate with the Pinnacle Logo, but on the main chip it just says
    Code:
    saa7134
    cc2306
    ti0332
    Here's my lspci ouput
    Code:
    00:00.0 Host bridge: Intel Corp. 82865G/PE/P Processor to I/O Controller (rev 02)
    00:01.0 PCI bridge: Intel Corp. 82865G/PE/P Processor to AGP Controller (rev 02)
    00:1d.0 USB Controller: Intel Corp. 82801EB USB (rev 02)
    00:1d.1 USB Controller: Intel Corp. 82801EB USB (rev 02)
    00:1d.2 USB Controller: Intel Corp. 82801EB USB (rev 02)
    00:1d.7 USB Controller: Intel Corp. 82801EB USB2 (rev 02)
    00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev c2)
    00:1f.0 ISA bridge: Intel Corp. 82801EB LPC Interface Controller (rev 02)
    00:1f.1 IDE interface: Intel Corp. 82801EB Ultra ATA Storage Controller (rev 02)
    00:1f.3 SMBus: Intel Corp. 82801EB SMBus Controller (rev 02)
    00:1f.5 Multimedia audio controller: Intel Corp. 82801EB AC'97 Audio Controller (rev 02)
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R300 ND [Radeon 9700 Pro]
    01:00.1 Display controller: ATI Technologies Inc Radeon R300 [Radeon 9700 Pro] (Secondary)
    02:05.0 Ethernet controller: 3Com Corporation 3c940 1000Base? (rev 12)
    02:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
    02:0a.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 04)
    02:0a.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
    02:0c.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)
    And I'm using a patched 2.4.24 kernel (patch-2.4.24-rc1-kraxel from bytesex.org)

    Thanks for taking the time

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Now that's quite a surprise. I thought Pinnacle only made board with Brooktree chips.

    One thing that you should try is upgrading to the latest version of xawtv from bytesex.org. It uses the Xvideo extension to render the overlay. That also means that you'll have to alter your /etc/X11/XF86Config (to support bridging v4l to XV). That's really simple, though: just add `Load "v4l"' to the `Module' section on your XF86Config (and restart your X server).

    If that doesn't do it, could you please unload the modules, reload them, and post the output of `dmesg | tail -30'?

  6. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    Thanks for the pointers Dolda. I already have the latest version of xawtv, but the suggested modification to the XF86 conf definetly improved things, xawtv doesn't spit out a continious flow of errors in the console when running. And xawtv-hwscan now gives :
    Code:
    port 59-59                              [ -xvport 59 ]
        type : Xvideo, video overlay
        name : video4linux
    
    port 60-60
        type : Xvideo, image scaler
        name : ATI Radeon Video Overlay
    
    /dev/video0: OK                         [ -device /dev/video0 ]
        type : v4l2
        name : Pinnacle PCTV Stereo (saa7134)
        flags: overlay capture tuner
    I did a modprobe -r (I presume this is what you meant) on saa7134, tuner, td9887 and here is what dmesg | tail -30 gives :
    Code:
    saa7134[0]: found at 02:0c.0, rev: 1, irq: 20, latency: 64, mmio: 0xfeafb400
    saa7134[0]: subsystem: 11bd:002b, board: Pinnacle PCTV Stereo (saa7134) [card=26,insmod option]
    saa7134[0]: board init: gpio is 0
    i2c-core.o: adapter saa7134[0] registered as adapter 0.
    saa7134[0]: i2c eeprom 00: bd 11 2b 00 f8 f8 1c 00 43 43 a9 1c 55 d2 b2 92
    saa7134[0]: i2c eeprom 10: 00 00 19 0e ff 20 ff ff ff ff ff ff ff ff ff ff
    saa7134[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 53 ff ff ff ff
    saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    i2c-core.o: driver i2c TV tuner driver registered.
    tuner: chip found @ 0xc0
    tuner: type set to 33 (MT20xx universal)
    tuner: microtune: companycode=3cbf part=42 rev=09
    tuner: microtune MT2050 found, OK
    i2c-core.o: client [MT20xx universal] registered to adapter [saa7134[0]](pos. 0).
    i2c-core.o: driver i2c tda9887 driver registered.
    tda9887: chip found @ 0x86
    tuner: type already set (33)
    i2c-core.o: client [tda9887] registered to adapter [saa7134[0]](pos. 1).
    saa7134[0]: registered device video0 [v4l2]
    saa7134[0]: registered device vbi0
    saa7134[0]: registered device radio0
    saa7134[0]: registered device dsp1
    saa7134[0]: registered device mixer1
    saa7134[0]/audio: audio carrier scan failed, using 5.500 MHz [default]
    i2c-core.o: client [MT20xx universal] unregistered.
    i2c-core.o: client [tda9887] unregistered.
    i2c-core.o: adapter unregistered: saa7134[0]
    i2c-core.o: driver unregistered: generic i2c audio driver
    i2c-core.o: driver unregistered: i2c TV tuner driver
    i2c-core.o: driver unregistered: i2c tda9887 driver
    I'm still experimenting with Linux, so I apologise if this seems messy (I'm not sure I've done it right). I'm still not getting any signal, but I'm one step further...

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Have you tried the `scantv' command?

  8. #7
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    scantv gives a similar result to tvtime-scanner
    Code:
    scanning channel list europe-west...
    E2   ( 48.25 MHz): no station
    E3   ( 55.25 MHz): no station
    E4   ( 62.25 MHz): no station
    S01  ( 69.25 MHz): no station
    S02  ( 76.25 MHz): no station
    ...
    I have checked on my tv provider's site and these are definitly the correct frequencies (PAL - western europe)

    Xawtv only reports the following in the shell once it's running : Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct but I presume this isn't vital

  9. #8
    Just Joined!
    Join Date
    May 2004
    Location
    U.K.
    Posts
    8

    Pinnacle TV

    I had one of these cards and at the time their was no support for the sound chip, I notice from your lspci list that the bttv module is not loaded this is required for these cards because they do use the bt878 chip, do a lsmod to see if your kernel has the bttv module, if it has insmod bttv, or you can just do a modprobe bttv, then run scantv you should hear the sound of different channels as the scan progresses and as it finds channels it will pause momentarily trying to assertain which channel its found, you should see this channel list as it finds channels.
    When scantv is finished start xawtv you should now have a picture.

  10. #9
    Just Joined!
    Join Date
    Apr 2006
    Posts
    8
    Nowadays this TV card is supported with the 2.6.x kernel, for TV viewing only. Capturing audio is not yet supported by the v4l2 module (driver). Is there any progress in developping sound-capture support for this card yet? For the life of me, I cannot seem to find a hint towards future suport for this card on the v4l2 (wiki)site...

    Will we ever be able to use this exellent card as a video recording device???

  11. #10
    Just Joined!
    Join Date
    Apr 2006
    Posts
    8
    Wait a minute. The v4l2 site states only audio for viewing supported. No. I got video and audio capture woring now! Via alsa (capture w/ mencoder). My capture command:

    Code:
    mencoder -tv driver=v4l2:device=/dev/video0:alsa:adevice=hw.0,0:outfmt=yuy2:width=720:height=576:fps=25:chanlist=europe-west:audiorate=48000:freq=$freq -o "$output_file" -oac lavc -ovc lavc -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=9800:vbitrate=6000:keyint=15:aspect=1.3333:acodec=mp2:abitrate=224 tv://
    Where:
    $freq = broadcast frequequency of the channel/programme.
    $out_file = output file.

    It captures to MPEG2 audio/video. To make a DVD out of the file you have to use Avidemux2 and process the file to 'mpeg2 PS a+v' and do not re-encode audio nor video.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •