Find the answer to your Linux question:
Results 1 to 2 of 2
hey everybody, i've googled and couldn't find any problems related to this one, so here we go... i just installed fc5... and then xmms and xmms-mp3. when i double click ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    lauching xmms w/ double click issue...


    hey everybody,

    i've googled and couldn't find any problems related to this one, so here we go...

    i just installed fc5... and then xmms and xmms-mp3. when i double click on an mp3 it won't play, however, if i drag it into the playlist, click on the song on the playlist, it will play fine.

    if xmms isn't open and i click on the mp3, xmms will open up, however, the playlist that was last used will appear (with the song i clicked on not being played or added to the playlist). if i click on a song while xmms is open, it will try to launch xmms again, but it can't cause it's set not to, so it will be weird and "attempt" to load for like 2 minutes then die out. i'm not sure what the issue is here... i have all the settings to default... deleted my entire .xmms directory... still does the same thing.

    so what do i want? well, basically, if i click on a song it should play in the current instance of xmms...

    any suggestions? i've been working on this problem for a few days now with no success. i'm baffled. i have another linux box with fc3 on it and the functionality works fine on it.

    not sure if it matters but i'm using kde on my fc5 box and gnome on my fc3 box.

    i'm also using the latest version of xmms/xmms-mp3, installed using livna repo.

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    xmms won't play after double click on file

    Here's what I did:

    As root, removed -e parameter from xmms command line execution in:
    /usr/share/desktop-menu-patches/redhat-audio-player.desktop

    Then, using Konqueror in filemanagement mode, navigate to a wave, mp3, or what-have-ya. Right click on the file and select "Properties."

    Left click on the 'tools' icon on the right side of the window across from "Type:" to bring up the "Edit File Type audio/x-???? -KeditFileType" window. On the "General" tab, in the "Application Preference Order" window, highlight "Audio Player" (xmms), and then click "Edit . . . "

    In the "Properties for redhat-audio-player.desktop" window, click the "Application" tab. In the "command" box, remove the -e parameter.

    You may need to do this for all file types that you expect to play immediately through xmms (haven't quite gotten that far . . .)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •