Find the answer to your Linux question:
Results 1 to 3 of 3
I have installed ET but the sound doesnt work. I tried to use the command that seems to work for a lot of people. echo "et.x86 0 0 direct" > ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Enemy territory No sound


    I have installed ET but the sound doesnt work.
    I tried to use the command that seems to work for a lot of people.
    echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

    Somehow it worked. And I could play with sound for a few days. But then suddenly the sound was gone again and the command doesn't work anymore.
    I use gnome..
    Someone has an idea what's the problem here?

    Brecht

  2. #2
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Notice that your command doesn't store anything.
    You have to redo it after every reboot.

    If it really doesn't do anything anymore (this should normally give you an error message), also try:
    echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss

    If that still doesn't work:
    *post the error message
    *what driver module are you using?

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    2

    Wink permanent fix

    here's a more permanent fix and explanation of the:
    echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

    what this does is temporarily enters "et.x86 0 0 direct" into oss.
    to make this more of a permanent entry, first:
    sudo gedit /proc/asound/card0/pcm0p/oss

    next type into oss:
    et.x86 direct

    now save and you should be set for life.

    i know it seems obvious, but people were asking how to make this more permanent, there you go.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •