Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, im getting this error after I updated my nvidia drivers on Suse 9. WHen I first loaded the operating system and fired up UT i had a very laggish ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    12

    Suse 9.0 Graphics problems


    Hi, im getting this error after I updated my nvidia drivers on Suse 9. WHen I first loaded the operating system and fired up UT i had a very laggish picture, sound, and mouse. I updated the driver and now nothing will start. Here is the error:

    Bigmack@pcp02483593pcs:/usr/local/games/ut2004demo> sh ut2004demo
    Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

    History:

    Exiting due to error

    If you know how to fix it can you give me a detailed explaination on how to fix it? thnx.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    When u say that you updated the NVIDIA drivers do you mean you used YaST Online Update (YOU) or did u download the latest drivers from nvidia.com?
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    12

    Yes

    Yea, i used Yast and it downloaded and installed the drivers. One inidicator is that i attempted to use UT and all senses were lagging alot plus you couldnt see **** and now after i did the update the game wont start. So common sense tells me that it updated. Im not basing this off of what the game does, its just a second indicator. I watched them download and install.

  4. #4
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    instead of updating the drivers through YaST, try downloading the latest ones from www.nvidia.com (will need the Linux IA32 one. Should be a file called NVIDIA-Linux-x86-1.0-5336-pkg1.run.

    hit Ctrl + alt + F1 and log in as root.

    type init 3 to go to runlevel 3 (Need to do this to install graphics drivers)

    cd /path/to/where/you/stored/the/driver
    sh NVIDIA-Linux-x86-1.0-5336-pkg1.run
    sax2 -m 0=nvidia (this is the number ZERO, not the letter O)
    then go thru the prompts on screen (if there are any)
    When it's back to the command line type
    init 5
    to return to X and u should now have the new drivers running fine!!
    Any probs, pm me!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  5. #5
    Just Joined!
    Join Date
    Apr 2004
    Posts
    12
    Thanx a bunch, that worked. Although, it did mention updating something else for 3D accelleration support. Could that be why I can only run UT in 16bit graphics mode? As far as ut2k4 goes, it works like a charm. thanks again.

  6. #6
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    I don't know much about the 3d graphics meself, i never got it working, but if u goto a shell and type
    Code:
    glxgears
    that gives u info on ur frame rate etc, and that only runs if 3d is enabled, i dunno what goes on, as it sex it's disabled, but allows that!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  7. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    2

    OpenGL

    When I was using SUSE (toying with it for a time) I noticed that my card couldnt get 3D Accelleration either. Apparantly SUSE uses OpenGL for 3D Accelleration, so you will need those kind of drivers for your card. However, I am unsure if this 3D acceleration is for desktop enhancements and GUI stuff in general or if it reffers to games (which, according to my limited understanding, have the ability to access most cards native hardware based 3D acceleration, thjough I could be wrong, or just thinking of DirectX)

    Well, thats all I can say, really.

    Speaking of DirectX (I'm still pretty new to Linux in general) do they make a version for Linux? Or is M$ just THAT stingy?

  8. #8
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    i don't think M$ will start to make directX for linux ever. You may get some developers out there that evenually get a very similar prog that does the same thing though. As for the 3D accelleration, i think it works, but for some reason it doesn't appear to be selected. e.g. if i try to play something like TuxRacer without the NVidia drivers installed, it looks AWFUL, and says i need 3D Graphics enabled, so i installed em, and tried it again without the option of 3D graphs in Sax2 being enabled, and the game runs, and says NOTHING about the 3D not being enabled, so i am not sure bout that meself!!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •