Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, My soundcard seems to be recognized by Fedora Core 6, but when I press the test sound button, the sound plays but with a very high-pitched sound in the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie tvilkov's Avatar
    Join Date
    Jan 2007
    Location
    Moscow
    Posts
    136

    Question Sound is not working properly


    Hello,
    My soundcard seems to be recognized by Fedora Core 6, but when I press the test sound button, the sound plays but with a very high-pitched sound in the background, making it almost impossible to listen to music. Now, when I open up an mp3 file in any media player, the result is the same as with the sound test. However, when I try to lower or raise the volume using the players' volume control, the sound totally dissapears, and I can't get it back again, only rebooting helps. I've looked at alsa mixer and everything, but nothing seems to be muted. Any ideas? My soundcard is intergrated SoundMAX ADI AD1986A. ALSA sees it as MPC61 High Definition Audio, nVidia Corporation, and it uses snd-hda-intel module. ALSA version 1.0.12. I think it might be the module or the driver, but I have got no idea how to change the driver. Please help!

  2. #2
    Linux Newbie burntfuse's Avatar
    Join Date
    Nov 2006
    Location
    Laurel, MD
    Posts
    158
    Do you have a file in /etc called modprobe.conf or modules.conf?

    If it's the right driver for the soundcard, then changing it isn't going to help (it's not like there are tons of drivers for the same hardware floating around online). This sounds more like something you should report on the Fedora bug tracker, since it should be setting up your soundcard to work out of the box.
    I have sold my soul to the penguin

  3. #3
    Linux Newbie tvilkov's Avatar
    Join Date
    Jan 2007
    Location
    Moscow
    Posts
    136

    Hello,

    The volume still mutes when I change the volume settings during the playback (although rhythmbox works fine!). I have managed to get rid of the high pitched sound by playing around with the alsamixer. I've muted my left speaker, and the horrible sound is gone! However, the actual speaker isn't muted. Strange, but it works for now. Thanks.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie tvilkov's Avatar
    Join Date
    Jan 2007
    Location
    Moscow
    Posts
    136
    Well, i have found the solution to this problem. In /etc/modprobe.d, in file modprobe.conf.dist I have added the following line under the alsa modules -
    options snd-hda-intel position_fix=1 model=3stack

    Now it works fine without any problems.
    Gentoo 2.6.24 amd64
    AMD Anthlon 64 X2, 2 GB RAM, Asus M2N-MX, nVidia GeForce 9600GT 512Mb, 250Gb + 160Gb HDDs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •