Find the answer to your Linux question:
Results 1 to 7 of 7
anybody know why my mplayer won't play videos in full-screen mode? It occupies the whole screen with the -fs switch, but it's got a huge black border round the video ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2006
    Posts
    123

    videos full screen?


    anybody know why my mplayer won't play videos in full-screen mode?
    It occupies the whole screen with the -fs switch, but it's got a huge black border round the video which is in a small rectangle in the centre.
    I've tried adding the -zoom parameter but the video then plays slower than the sound (albeit smoothly). I've got the nvidia graphics card drivers installed as the full-screen nvidia logo comes on at startup, and doing "glxinfo | grep direct" returns "Direct rendering: Yes".
    executing "mplayer -fs -zoom myavi.avi" prints:
    Code:
    [ben@benlinux ~]$ mplayer -fs -zoom myvideo.avi
    MPlayer 1.0rc1-rpm.livna.org-4.1.1 (C) 2000-2006 MPlayer Team
    CPU: AMD Duron(tm) Processor (Family: 6, Model: 7, Stepping: 1)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing myvideo.avi.
    AVI file format detected.
    VIDEO:  [DX50]  576x320  12bpp  25.000 fps  969.1 kbps (118.3 kbyte/s)
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
    Xlib:  extension "XVideo" missing on display ":0.0".
    Sorry, Xv not supported by this X11 version/driver
    ******** Try with  -vo x11  or  -vo sdl  *********
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [liba52] AC3 decoding with liba52
    Using SSE optimized IMDCT transform
    Using MMX optimized resampler
    AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
    Selected audio codec: [a52] afm: liba52 (AC3-liba52)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 576 x 320 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.80:1 - prescaling to correct movie aspect.
    VO: [x11] 576x320 => 576x320 Planar YV12  [fs] [zoom]
    SwScaler: using unscaled yuv420p -> rgb32 special converter
    A:   2.8 V:   2.2 A-V:  0.602 ct:  0.021  55/ 55 52% 70%  1.7% 50 0
    
               ************************************************
               **** Your system is too SLOW to play this!  ****
               ************************************************
    
    Possible reasons, problems, workarounds:
    - Most common: broken/buggy _audio_ driver
      - Try -ao sdl or use the OSS emulation of ALSA.
      - Experiment with different values for -autosync, 30 is a good start.
    - Slow video output
      - Try a different -vo driver (-vo help for a list) or try -framedrop!
    - Slow CPU
      - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
        e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
    - Broken file
      - Try various combinations of -nobps -ni -forceidx -mc 0.
    - Slow media (NFS/SMB mounts, DVD, VCD etc)
      - Try -cache 8192.
    - Are you using -cache to play a non-interleaved AVI file?
      - Try -nocache.
    Read DOCS/HTML/en/video.html for tuning/speedup tips.
    If none of this helps you, read DOCS/HTML/en/bugreports.html.
    
    A:   4.4 V:   3.9 A-V:  0.525 ct:  0.018  98/ 98 46% 61%  1.9% 89 0
    Exiting... (Quit)
    [ben@benlinux ~]$
    this is really pissing me off, every time I think I have got a linux installation with all the capabilities I want from it I discover something it won't do, or it changes its behaviour and suddenly refuses to do something that it would do before. Previously it failed to read my camera and I had to reinstall it 'cos I didn't know what the problem was and neither did anybody here, now it's failing to play AVIs properly. The annoying thing is every thing I want it to be able to do linux has proved itself capable of doing at some point or other, just not all together, consistently! aaaarrrrghh...

    At the top of the mplayer output, it says "mplayer: No such file or directory" - did they not think when writing it, it might be handy if they'd put in the error output what file it wanted that it couldn't find?

    Any ideas?

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    this happened to me once too try:

    mplayer -vo sdl video.avi


    or some of the other video outs listed by

    mplayer -vo help
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Use gl2 and no double buffering, something like this

    mplayer -vo gl2 -nodouble file.mpg
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. #4
    Linux Newbie
    Join Date
    Nov 2006
    Posts
    123
    Quote Originally Posted by Juan Pablo
    Use gl2 and no double buffering, something like this

    mplayer -vo gl2 -nodouble file.mpg
    that makes mplayer crash, but it outputs:
    Code:
    [ben@benlinux ~]$ mplayer -vo gl2 -nodouble -fs -zoom partridge205.avi
    MPlayer 1.0rc1-rpm.livna.org-4.1.1 (C) 2000-2006 MPlayer Team
    CPU: AMD Duron(tm) Processor (Family: 6, Model: 7, Stepping: 1)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing partridge205.avi.
    AVI file format detected.
    VIDEO:  [DX50]  576x320  12bpp  25.000 fps  969.1 kbps (118.3 kbyte/s)
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [liba52] AC3 decoding with liba52
    Using SSE optimized IMDCT transform
    Using MMX optimized resampler
    AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
    Selected audio codec: [a52] afm: liba52 (AC3-liba52)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 576 x 320 (preferred colorspace: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.80:1 - prescaling to correct movie aspect.
    SwScaler: using unscaled yuv420p -> bgr24 special converter
    VO: [gl2] 576x320 => 576x320 BGR 24-bit  [fs] [zoom]
    [gl2] You have OpenGL >= 1.2 capable drivers, GOOD (16bpp and BGR is ok!)
    [gl2] antialiasing off
    [gl2] bilinear linear
    A:   1.3 V:   0.1 A-V:  1.181 ct:  0.008   4/  4 ??% ??% ??,?% 3 0
    
    MPlayer interrupted by signal 15 in module: flip_page
    [ben@benlinux ~]$

    I've found using -framedrop enables the video to keep up with the sound, and thus makes it watchable, but it's flickery every so often, as the name implies - it's dropping frames.

    What I don't understand is if I do just "mplayer myvideo.avi" it plays it fine.
    But it's when I try and add the -zoom flag to make it do it in full-screen mode that it struggles.
    I'm sure it should make the video fill the screen without me needing to add the zoom parameter, instead of having a great black border - as it has done it without problems on previous installatinos without needing the 'zoom' parameter....

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    The most compatible output is certainly x11 :
    Code:
    mplayer -vo x11 -zoom your_movie.avi
    If that works you can configure a proper ~/.mplayer/config file so those options are the default ones.

    The -zoom switch is only for x11 software rendering mode : other outputs don't need -zoom. If your video card supports it, the xv output is perhaps the fastest/lightest one.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Linux Newbie
    Join Date
    Nov 2006
    Posts
    123
    Quote Originally Posted by antidrugue
    The most compatible output is certainly x11 :
    Code:
    mplayer -vo x11 -zoom your_movie.avi
    If that works you can configure a proper ~/.mplayer/config file so those options are the default ones.

    The -zoom switch is only for x11 software rendering mode : other outputs don't need -zoom. If your video card supports it, the xv output is perhaps the fastest/lightest one.
    Well, the default -vo must be x11 then - because it does need zoom. Still, doesn't explain why it's slower with zoom than not....but good point about where the defaults are stored.

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    30

    XVideo

    Try enabling XVideo extension if possible, or else add a -framedrop option which will help with A/V desync. In KPlayer it's at Settings - Configure KPlayer - Advanced - Frame Dropping. The soft one is the one you need.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •