Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm trying to change the font and resolution of the TTY(0-6) consoles. Can anybody help me out on this? TIA Indro...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Question Howto change TTY Fonts ?


    Hi,
    I'm trying to change the font and resolution of the TTY(0-6) consoles. Can anybody help me out on this?

    TIA
    Indro

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    24
    you need to compile your kernel with frame buffer enabled (if it isn't already). You can then select the resolution to use at boot time by passing an arguement to the kernel. Here's my /etc/lilo.conf if it's any use to you:


    Code:
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    root = /dev/hdb2
    message = /boot/boot_message.txt
    prompt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # Normal VGA console
    # vga = normal
    # VESA framebuffer console @ 1024x768x64k
    # vga=791
    # VESA framebuffer console @ 1024x768x32k
    # vga=790
    # VESA framebuffer console @ 1024x768x256
    # vga=773
    # VESA framebuffer console @ 800x600x64k
    # vga=788
    # VESA framebuffer console @ 800x600x32k
    # vga=787
    # VESA framebuffer console @ 800x600x256
    # vga=771
    # VESA framebuffer console @ 640x480x64k
    # vga=785
    # VESA framebuffer console @ 640x480x32k
    # vga=784
    # VESA framebuffer console @ 640x480x256
    # vga=769
    # End LILO global section
    # Linux bootable partition config begins
    image = /boot/vmlinuz
    label = Linux
    read-only
    # Linux bootable partition config ends

  3. #3
    Just Joined! fatalexception's Avatar
    Join Date
    Feb 2007
    Posts
    34
    If you're not using Lilo, have a look at my 'kernel' line for grub in Ubuntu:
    Code:
    kernel          /boot/vmlinuz-2.6.17-11-386 **extra stuff omitted** ro vga=0x0362
    At the end it says vga=0x0362. You can append the vga option to this line, of course substituting my vga value for one that works for yours.

    Regardless of your bootloader, for the actual mode to use, I found mine out using a piece of software known as 'hwinfo'.
    Code:
    entity@domina:~$ sudo hwinfo --framebuffer | grep Mode          
      Model: "Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS Intel(r)915GM/910ML/915MS Graphics Controller"
      Mode 0x0360: 1280x800 (+1280), 8 bits
      Mode 0x0361: 1280x800 (+2560), 16 bits
      Mode 0x0362: 1280x800 (+5120), 24 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+832), 8 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
    Shows a list of modes your hardware is capable of producing.

    Good luck.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    33
    Hi, I am trying to do the same thing. I changed my lilo.conf file to set the proper resolution, and now it switches to that soon after beginning to boot; but then it switches back to default while booting, as the following lines scroll by:

    starting portmap daemon...
    setting console screens and fonts

    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •