Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hello All. I am very new here and this is my 1st install of Linux distro (fedora core 1) & I really need some help because getting video card drivers ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Location
    /US/FL/Orlando
    Posts
    94

    ATI video card driver install from hell


    Hello All.

    I am very new here and this is my 1st install of Linux distro (fedora core 1) & I really need some help because getting video card drivers installed should not be near as complicated as it seems with me. Maybe its just because I am new but here go's.

    I am running FC1 and have a ATI Radion 9800XT (failrly new card) and I downloaded the rpm. file and installed it. It asked me like 20-30 things in the installer that I really had no knowlege of so I kept all default just for safe keeping. Its says to make sure that the drivers are installed correctly to type "fglrxinfo" and if I see OpenGL vendor string: ATI Technologies Inc., then the drivers are installed correctly. So I rebooted before logging back into KDE. I saw my resolution was all low 640x480 so I went "system settings > display" and was on the 1st tab called "settings" I can see the resolution listed here but when I select it to change to something higher, it can't as if it is the only available resolution for the card...???!!! I then click ovewr to the next tab called "hardware" and both options "monitor" & "video card" are both unknown???

    What is wrong with my install when I followed the instruction to the tee?

    Someone please help me - this has been 14 day experience and need some closure.

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    /US/FL/Orlando
    Posts
    94
    just looking around and when I select the KDE menu (Accessories, Games, Graphics etc etc...)
    I see a folder that says "other" and in that folder has only one options called ATI Control - when I select this, I see an ATI logo flashing next to my mouse cursor and also open up in lower panel with a hour glass flipping and then just goes away after 30-40 sec's w/ no error.

    Really confused?

    I made sure that I downloaded the appropriate driver (3.9.0) for my Xfree86 version (4.3.0).


  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    2

    Mine works now :D

    Make sure you know what directory your Ati driver is that you downloaded.
    You have to know some basic linux commands. ( ls = displays the directory )
    For me to explain this is a bit difficult, because I am a Linux newbie also.
    MAKE SURE TO READ ATI'S INSTALLATION GUIDE FIRST.
    Several things You have to know ,
    like commands to get into " init 3" and logging in as root there,

    Quickest way to get there is, boot your computer, at the sign on screen, hit ctrl +alt+F1
    then log in as root. then type (init 3) without the bracets..

    http://ati.com/support/infobase/linuxhowto-ati.html

    some basic commands are listed here;
    http://www.sorgonet.com/linux/commands/

    hope this helps, I wish I had someone to tell me how. took me bout 2 hours to do, without instructions.. goodluck

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    what is listed under /etc/X11/XF86Config-4 that should tell you if X11 is actually "knowing" your card.......... the gui may not work perfectly...

    is ATI even listed........

    sorry, never used FC so can't help you there....

  6. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    Unfortunatly, untill ATI, Nvidia and the other graphics chip manufacturers open up the specifications for the cards it will allwase be a pain to install drivers. For example support for hardware is built into the linux kernel. the only reason that this is not so for graphics manufacturers is that the spec is closed so no-one can easiliy develop an open driver. Some support for ATI cards is included in the kernel "DRI" but I have no idea how far along it is.
    Sorry but I know nothing of RPM based distro's. In my distro (gentoo) all I have to do to install the drivers (and anything else) is type "emerge ati-drivers" I don't even have to go downloading things.. it does it for me:D (of course i need to edit the config file too: "/etc/X11/XFree86Config". This is probably the problem you are having.

    You could try this:

    Close down your X session and log in to the command line as root. Now type "/usr/X11R6/bin/xf86cfg" without the "" and press return. It should take you to a graphical configuration screen (Note: Xfree must _NOT_ be running or it wont work!). The best option is to ignore the crappy "wizards" and do things your self.. it is easyer and faster once you learn how!

  7. #6
    Just Joined!
    Join Date
    May 2004
    Location
    /US/FL/Orlando
    Posts
    94
    I typed that in exactly and got a "bash error" no such directory...???

    I thought maybe I needed to "cd" then that string but still - same error?

    Did I do something wrong?

  8. #7
    Just Joined!
    Join Date
    May 2004
    Location
    /US/FL/Orlando
    Posts
    94
    Guys - Am I suppose to mode some file before this all works?

    The ATI install guide says nothing about changing any file but some people say that had to alter something to get the drivers working?

    I just followed the step by step instructions for ATI -

  9. #8
    Just Joined!
    Join Date
    May 2004
    Posts
    2
    After your in init 3
    Building the fglrx kernel module:
    1. cd /lib/modules/fglrx/build_mod
    2. sh make.sh
    Installing the fglrx kernel module:
    3. cd /lib/modules/fglrx
    4. sh make_install.sh
    Note any error messages that appear during this process.
    The following message (or similar) should appear when the ATI kernel module has been installed successfully:
    ==============================
    - creating symlink
    - recreating module dependency list
    - trying a sample load of the kernel module
    Warning: loading /lib/modules/x.x.xx-x/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 20XX - ATI Technologies, Starnberg,

    The with warnings part is expected, and should not affect functionality.
    For each of these steps you will have to be logged on as the root user.

    1. cd to the directory containing the ATI Driver rpm package

    2. Issue the following command:

    rpm -Uh --force <ati_package_name>.rpm

    Note any error messages that may occur while installing (see below)
    3. Run the fglrxconfig utility to configure the driver
    * Answer the questions as prompted
    * When asked to generate an XF86Config-4 file, answer y

    4. Run fglrxinfo to verify the driver is installed correctly

    If the output reads OpenGL vendor string: ATI Technologies Inc. then your ATI drivers are installed and configured correctly.
    After this is done.. type fglrxconfig configure this and then contiinue to step 5,
    4. Restart and log into X-Windows
    This is what I used and it worked for me.

  10. #9
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1
    There are some excellent linux tutorials at the forums at rage3d.com

    Also, if you have an Nforce2 based motherboard, you'll want to check out the linux forum at nforcershq.com There are some specific nforce2 settings that must be used

    Also, make sure agpgart module is loaded, try to modprobe agpgart Then do the same with the fglrx modules. I seem to remember having a problem getting fedora to work because apgart wasn't loading automatically. Once I set that up in modules.conf, the fglrx module would load using the apgart module. When you run fglrxconfig, you MUST change the default answer to "Use external agpgart" to "Yes". The default of NO will almost never work on an ATI card.

    You may need to edit the /etc/X11/XF86Config-4 by hand to make sure the ATI entry is using driver "fglrx" and not radeon or vesa.

  11. #10
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1

    ATI driverss on Fedora Core 2?

    Hello Everyone! I want to ask if you know what kind of drivers are being used
    for ATI on Fedora Core! Because Fedora Core isn't using xfree86 like Fedora Core 1 it's using XORG! Plz help me!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •