Find the answer to your Linux question:
Results 1 to 3 of 3
Hello there, It's been a while since I've visited these forums. My new Gentoo installation is almost perfect, except... I have an nvidia EN7600GT video card, and use the latest ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie tvilkov's Avatar
    Join Date
    Jan 2007
    Location
    Moscow
    Posts
    136

    nvidia-settings "X Server Display Configuration" section missing


    Hello there,
    It's been a while since I've visited these forums. My new Gentoo installation is almost perfect, except...
    I have an nvidia EN7600GT video card, and use the latest video drivers from nvidia (100.14.09). Everything is fine, except during instalaltion (I did it through portage) there's an error ('kernel configuration is invalid' or something along those lines). The installation goes well, modules are built and inserted. The drivers work perfectly. However, since I watch DVD's from my computer on TV a lot, I need the TVOUT. However, the section in nvidia-settings GUI panel (titled "X Server Display Configuration") that allowed me to output to TV on Debian is now gone in Gentoo! I have tried recompiling, followed the Gentoo wiki guide on installing nvidia drivers, checked the kernel twice, recompiled it, but still theres that error, and the panel remains the same. What I have done so far to fix the problem, is copy the binary file nvidia-settings from Debian installation to Gentoo, and that has done the trick, but how do I properly fix this problem? Why does it happen? I have googled the problem, but I all I've found is how to set up TV output through xorg.conf, but that hasn't worked for me (TV resolution is all messed up etc). Any ideas? Thanks!
    Gentoo 2.6.24 amd64
    AMD Anthlon 64 X2, 2 GB RAM, Asus M2N-MX, nVidia GeForce 9600GT 512Mb, 250Gb + 160Gb HDDs

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I think with gentoo the only way to edit xorg.conf to set up twinview mode and then you may get the option in nvidia settings. Here is my xorg.conf section if it helps.

    Section "Device"
    Identifier "Nvidia"
    Driver "nvidia"
    Option "UseEdidDpi" "FALSE"
    Option "DPI" "96 x 96"

    Option "TwinView"
    Option "SecondMonitorHorizSync" "30-50:
    Option "SecondMonitorVertRefresh" "60"
    Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x
    480;"
    # Option "ConnectedMonitor" "CRT, TV"
    Option "TVStandard" "NTSC-M"
    Option "TVOutFormat" "SVIDEO"
    Option "TwinViewOrientation" "Clone"
    # unsupported card
    #VideoRam 262144
    # Insert Clocks lines here if appropriate
    EndSection
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Newbie tvilkov's Avatar
    Join Date
    Jan 2007
    Location
    Moscow
    Posts
    136
    I don't want to edit my xorg.conf at all! What I mean is the section in the nvidia panel that controls TV is missing. I guess it thinks that my TV card does not have a TV output. This has happened to me on Debian once, when I installed the kernel from unstable repo. I think it has sometihng to do with the kernel (and that little error..). Anyway, for now the panel that I got from Debian does the trick. But really, has no one had this problem?
    P.S. - your code did not help, unfortunately (the resolution is messed up, and the desktop is like stretched across TV and my monitor!). Anyway, thanks for your help!
    Gentoo 2.6.24 amd64
    AMD Anthlon 64 X2, 2 GB RAM, Asus M2N-MX, nVidia GeForce 9600GT 512Mb, 250Gb + 160Gb HDDs

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •