Find the answer to your Linux question:
Results 1 to 4 of 4
Dear LF users, I have now been scanning every thread, mailing-list and HOWTO that Google can find (these three will henceforth be called "pages") for about a week, all to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! linduxed's Avatar
    Join Date
    Aug 2003
    Location
    Sweden, Järfälla
    Posts
    87

    The Notorious ""XFree86-DRI" missing" problem...


    Dear LF users,

    I have now been scanning every thread, mailing-list and HOWTO that Google can find (these three will henceforth be called "pages") for about a week, all to find a solution to a widespread problem. A lot of you may have seen it:

    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    The question is quite simple. How do I get rid of this error?

    Debian-based-system-users do have the "Restricted Driver"-solution, however to me (Sabayon) and a lot of others, that's not very helpful. People fortunate enough to be using NVidia have also got it pretty easy, as the problem is generally solved by installing the latest drivers (this is my perception of the pages I've read so far).
    Because of the fact that there are pages that solve the mentioned cases, I'd like this thread to concentrate on the "non-Ubuntu-ATI" users.
    Here's the search with the most relevant hits.
    Countless of pages exist on the net regarding this problem, yet none have come up with a definite solution. However there are a couple of leads.

    First of all, people continuously suggest that this is a simple driver-updating procedure. This has on many pages been proven false, or at most a partial solution. I'm not sure if I've installed the drivers correctly (so feel free to request files); I downloaded and installed the closed drivers, which turned into a garbled screen, but it got fixed with the addition of a line in xorg.conf and a reboot (the line being "Option "KernelModuleParm" "agplock=0"", not sure if it was needed though).

    Secondly, a pretty clever post and a somewhat convincing paragraph (here, check out the bold line under "Important / Updates) has led me to believe that this problem is directly tied to XGL, the ATI desktop-acceleration. People have reported that firing up, for example, Gnome without XGL fixes the problem. This however is not a solution in my eyes as beryl and compiz are becoming somewhat of a standard lately (yes, I've got compiz too), which means that scripts that temporarily disable XGL before running DRI-demanding apps might be a solution. I'm not quite sure about that though as my experience tells me compiz is quite sensitive, and touching upon XGL would most likely wreck a compiz-session.

    I've seen people talking about commenting out DRI in the xorg.conf file, losing framerate but fixing the problem. I've honestly not tried this because commenting out DRI is not a solution, it's called sweeping the problem under the rug (and I'm not sure it will work either).

    I'm currently using a Radeon x300 with the 8.40.4 closed drivers on Sabayon.

    Here's my xorg.conf:
    # ************************************************** ********************
    # Module section -- this is an optional section which is used to specify
    # which run-time loadable modules to load when the X server starts up.
    # ************************************************** ********************
    # ************************************************** ********************
    # Server flags section. This contains various server-wide Options.
    # ************************************************** ********************
    # ************************************************** ********************
    # Input devices
    # ************************************************** ********************
    # ************************************************** ********************
    # Core keyboard's InputDevice section
    # ************************************************** ********************
    # ************************************************** ********************
    # Core Pointer's InputDevice section
    # ************************************************** ********************
    # ************************************************** ********************
    # Monitor section
    # ************************************************** ********************
    # Any number of monitor sections may be present
    # ************************************************** ********************
    # Graphics device section
    # ************************************************** ********************
    # Any number of graphics device sections may be present
    # ************************************************** ********************
    # Screen sections.
    # ************************************************** ********************

    Section "ServerLayout"

    # The Identifier line must be present
    #InputDevice "Synaptics1" "SendCoreEvents"
    #InputDevice "wacom1" "SendCoreEvents"
    #InputDevice "wacom2" "SendCoreEvents"
    #InputDevice "wacom3" "SendCoreEvents"
    Identifier "Main Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Mouse2" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"
    EndSection

    Section "Files"

    #FontPath "/usr/share/fonts/local/"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/TTF/"
    FontPath "/usr/share/fonts/75dpi/"
    FontPath "/usr/share/fonts/100dpi/"
    FontPath "/usr/share/fonts/corefonts"
    EndSection

    Section "Module"
    Load "dbe"
    Load "i2c"
    Load "glx"
    Load "ddc"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "synaptics"
    Load "vbe"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "true"
    EndSection

    Section "InputDevice"

    #Option "MaxSpeed" "0.7"
    #Option "MinSpeed" "0.18"
    #Option "AccelFactor" "0.08"
    #Option "TopEdge" "120"
    #Option "LeftEdge" "120"
    #Option "BottomEdge" "830"
    #Option "RightEdge" "650"
    #Option "FingerLow" "25"
    #Option "FingerHigh" "30"
    # MacBook touchpad
    #Option "MaxTapTime" "180"
    #Option "MaxTapMove" "220"
    #Option "MaxDoubleTapTime" "180"
    #Option "VertScrollDelta" "20"
    #Option "HorizScrollDelta" "50"
    #Option "TapButton2" "3"
    #Option "TapButton3" "2"
    #Option "VertTwoFingerScroll" "1"
    # Do you keep moving the mouse while typing? Try this trick.
    #synclient TouchpadOff=1 disable your synaptics touchpad
    #synclient TouchpadOff=0 enable your synaptics touchpad
    Identifier "Synaptics1"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizScrollDelta" "0"
    Option "SHMConfig" "on"
    # For ALPS/MacBook TouchPads
    EndSection

    Section "InputDevice"

    #Option "XkbOptions" "lv3:rwin_switch"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 5"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "se"
    Option "XkbRules" "xorg"
    # Macintosh keyboard
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "wacom1"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "wacom2"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "wacom3"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"

    # Identifier and driver
    Identifier "Mouse1"
    Driver "mouse"
    Option "Device" "/dev/psaux"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse2"
    Driver "mouse"
    Option "Protocol" "ImPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "KernelModuleParm" "agplock=0"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    #Option "Composite" "enable"
    EndSection
    I'm intentionally leaving Xorg.0.log out as mine seems to be like nine screens long so if you need something from it just tell me.

    linduxed

  2. #2
    Just Joined! linduxed's Avatar
    Join Date
    Aug 2003
    Location
    Sweden, Järfälla
    Posts
    87
    I spoke to a guy on IRC and he suggested that the problem went away for him when doing a "Modular Xorg".

    What does this mean and could this help?

  3. #3
    Just Joined! linduxed's Avatar
    Join Date
    Aug 2003
    Location
    Sweden, Järfälla
    Posts
    87

    Mission Impossible

    After some serious googling and daily IRCing I have finally given up. The setup I was talking about was ATI + Xgl, and it turns out there is little hope for it.

    As you all know Xgl is what works for ATI, some sources say AIGLX is possible to run for non-nvidia but I doubt it strongly. That leaves ATI with one choice.

    Recently some guys at #sabayon informed me of the fact that Xgl lacks both dual-support and it can't run OpenGL on top of it self.

    It seems like the guy who wrote the "clever post" in post #1 was right in his deductions.

    Unless someone feels like recoding Xgl entirely and would like to inform me of this , I'm seeing this case as closed. The best bet is to completely disable Xgl if you need some OpenGL app, and then restart X.org with Xgl for normal usage...

  4. #4
    Just Joined! linduxed's Avatar
    Join Date
    Aug 2003
    Location
    Sweden, Järfälla
    Posts
    87
    Lately I got to know that the latest "ati-drivers" supports AIGLX, which is supposed to eliminate this problem alltogether.

    While the original problem seems to lack a solution still, this is a nice replacement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •