Find the answer to your Linux question:
Results 1 to 8 of 8
I installed Gentoo onto my USB external hard drive, I performed a networkless install and everything installed fine. However, when I try to boot from this external hard drive, I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4

    Can't Start Gentoo from USB Hard Drive


    I installed Gentoo onto my USB external hard drive, I performed a networkless install and everything installed fine. However, when I try to boot from this external hard drive, I get the following error:

    root (hd1, 0)
    Filesystem type unknown, partition type 0xde

    ... (two lines of unreadable characters and symbols)

    Error 17: Cannot mount selected partition

    Press any key to continue...
    I press a key and it takes me to the Grub menu, where I can select to boot Gentoo Linux. When I try to boot from Gentoo Linux I just get the above error. The Grub menu is almost completely unreadable, there are lines all over the place, making it hard to read the text. I am very new to linux and would appreciate any help you could give me.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and welcome.
    Did you format this drive during the install? Did you change it to a different type?
    boot up the Gentoo LiveCd and post the output of these commands.
    fdisk -l (lowercase L)
    more /boot/grub/grub.conf
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    I formatted according to the installer's recommended layout; I believe it is as follows: a small partition for swap, a small ext2, and a large ext3 partition.

    When i entered the fdisk -l command(into terminal, right?), nothing come up.
    I entered the more /boot/grub/grub.conf command and got the following:

    No such file or directory.

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You need to try this command as the root user
    su -
    (root password)
    /sbin/fdisk -l
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Is there a default password for root? I never entered one for the LiveCD, and the password for my installation doesn't work. What should I enter for the password?

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    When you installed it to the HD, it should have asked you to set a root password. I guess try using sudo
    sudo /sbin/fdisk -l
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    When I entered sudo /sbin/fdisk -l I got a bunch of information about both my internal(sda) and external hard drives(sdb). For my external hard drive it showed three Linux partitions. However, when I entered the more /boot/grub/grub.conf again, the file/directory doesn't exist.

  8. #8
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1
    Quote Originally Posted by MrSpecial View Post
    When I entered sudo /sbin/fdisk -l I got a bunch of information about both my internal(sda) and external hard drives(sdb). For my external hard drive it showed three Linux partitions. However, when I entered the more /boot/grub/grub.conf again, the file/directory doesn't exist.
    I had a similar problem with a hard drive install which might not be related but here goes..

    I had installed to hda1 which is formatted as ext3.

    I had the same error as you. I took me a while to notice that I had the ID types for my swap and / the wrong way round.

    In fdisk that would be option t and type 82 for the swap and 83 for the main partition. Also make sure that you have marked your partition as bootable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •