Find the answer to your Linux question:
Results 1 to 5 of 5
This is really weird.. When I do Code: emerge -av dev-lang/php dev-php5/jpgraph base I get a error for php that I need to enable to following use flags. Code: cli ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429

    USE Flags Problem.


    This is really weird..
    When I do
    Code:
    emerge -av dev-lang/php dev-php5/jpgraph base
    I get a error for php that I need to enable to following use flags.
    Code:
    cli pcre xml zlib
    And when you check my make.conf file it says:
    Code:
    USE="apache2 cli gd mysql pcre php png session ssl xml zlib"
    I dont know for sure but in
    Code:
    USE="apache2 cli gd mysql pcre php png session ssl xml zlib"
    I clearly see them.
    So what am I doing wrong?
    Have I maybe took two use flags that are struggling together?

    I hope there is somebody who can help me with this
    New Users, please read this..
    Google first, then ask..

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Does "emerge -puDvN world" report something?

    If affirmative, some package need to be recompiled (probably including php). Just throwing your use flags on your make.conf doesn't help. The "effects" are not applied until you recompile the involved packages to add the required support.

  3. #3
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    I fixed it yesterday. ^^
    Thanks though. I still dont know what the problems was...
    I just reemrged everything once and updated the system. Rebuilded the kernel rebooted and it worked.
    New Users, please read this..
    Google first, then ask..

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by RobinVossen View Post
    I fixed it yesterday. ^^
    Thanks though. I still dont know what the problems was...
    I just reemrged everything once and updated the system. Rebuilded the kernel rebooted and it worked.
    Just for future reference, If you add use flags to /etc/make.conf, sometimes a LOT of packages already installed, need to recompile again to make use of the new use flags. Sometimes it's helpfull to include the use flags to the emerge command like this:
    USE=win32codecs emerge -av mplayer
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by MikeTbob View Post
    Just for future reference, If you add use flags to /etc/make.conf, sometimes a LOT of packages already installed, need to recompile again to make use of the new use flags. Sometimes it's helpfull to include the use flags to the emerge command like this:
    USE=win32codecs emerge -av mplayer
    That is what the -N parameter stands for. A simple "emerge -uDvN world" would suffice, as I explained above. It will recompile everything that needs a change due to new USE flags settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •