Find the answer to your Linux question:
Results 1 to 5 of 5
I would like to learn Gentoo, so I installed it in a VMware virtual machine, it took me about four hours to install and forty three hours to update, finally, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    61

    need your help, thanks!


    I would like to learn Gentoo, so I installed it in a VMware virtual machine, it took me about four hours to install and forty three hours to update, finally, I still didn't have openoffice, Gimp and other applications, the terrible time-consuming process frightened me, the worst part is the firefox froze all the time, however, I do like to learn and use emerge and portage, so I switched to Sabayon yesterday, now it runs well in the virtual machine, but there are two problems I need your help, many thanks for any reply!

    1. I set the default locale to be English (LANG=en_US), but I find folders and files named with Traditional Chinese are not displayed correctly, all the names are question marks, "???", besides, I can not either find Traditional Chinese input option in SCIM setting, although I have installed scim-m17n, so what packages do I have to install for these requirements?

    PS : I don't want to change the locale to Chinese.

    2. When I tried the Sabayon PE liveCD, it played music while launching the desktop, then I install it into the virtual machine, but there is no more sound card detected, and pops up this information window Picasa Web Albums - 鈞丞 - Sabayon.

    I run lspci/lsmod and the sound card is listed, I run alsaconf and all the settings are correct, then I re-install alsa-lib, but no help, I just wonder why the sound card works while running liveCD but doesn't after installation? and how can I get the sound card working?

    # lspci
    02:01.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)

    $ lsmod
    Module Size Used by
    bluetooth 52580 0
    ipv6 258532 12
    snd_seq_midi 9344 0
    snd_seq_dummy 4868 0
    snd_seq_oss 30592 0
    snd_seq_midi_event 7936 2 snd_seq_midi,snd_seq_oss
    snd_seq 47600 6 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq_mid i_event
    snd_ens1371 25760 0
    gameport 16008 1 snd_ens1371
    snd_rawmidi 23680 2 snd_seq_midi,snd_ens1371
    snd_seq_device 8972 5 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq,snd _rawmidi
    snd_ac97_codec 93476 1 snd_ens1371
    ac97_bus 3456 1 snd_ac97_codec
    ac 7172 0
    battery 14340 0
    power_supply 11268 2 ac,battery
    pcnet32 31620 0
    i2c_piix4 9484 0
    i2c_core 24448 1 i2c_piix4
    shpchp 32276 0
    pci_hotplug 15112 1 shpchp
    intel_agp 24468 1
    pcspkr 4096 0
    tg3 101508 0
    e1000 112832 0
    scsi_wait_scan 2432 0
    sl811_hcd 12928 0
    uhci_hcd 23952 0
    ehci_hcd 32396 0

  2. #2
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    I used to have a problem with Sound aswell.
    I fixed that by putting the sound on.. -.-'
    Try AlsaMixer and check again
    New Users, please read this..
    Google first, then ask..

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    61
    The sound problem is solved.

    I still need helps to solve the problems of displaying and inputing Traditional Chinese, I run "echo 'zh_TW.UTF-8 UTF-8' >> /etc/locale.gen" to add support of Traditional Chinese, but it seems to be useless, any more solutions?

    BTW, I emerge scim and scim-tables, after that, I still can not launch scim to input, so I search the web and find I have to install package scim-qtimm, but I get the error message:

    * ERROR: app-i18n/scim-qtimm-0.9.4 failed.
    * Call stack:
    * ebuild.sh, line 1717: Called dyn_setup
    * ebuild.sh, line 768: Called qa_call 'pkg_setup'
    * ebuild.sh, line 44: Called pkg_setup
    * scim-qtimm-0.9.4.ebuild, line 31: Called die
    * The specific snippet of code:
    * die "You need to rebuild >=x11-libs/qt-3.3.4 with immqt-bc(recommended) or immqt USE flag enabled."
    * The die message:
    * You need to rebuild >=x11-libs/qt-3.3.4 with immqt-bc(recommended) or immqt USE flag enabled.
    *

    I search in Gentoo handbook and don't know how to "rebuild >=x11-libs/qt-3.3.4 with immqt-bc" , then I try to add ">=x11-libs/qt-3.3.4 immqt immqt-bc" in /etc/portage/package.use, but it seems to be useless, need more helps, thanks a lot!

  4. #4
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Sorry cant help you that. I never did need Chinese Signs since I cant read then.
    You might want to ask your Local Linux Comunity since they all have to include Chinese to the local.gen.

    I hope that helped.

    Cheers,
    Robin
    New Users, please read this..
    Google first, then ask..

  5. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Do this
    Code:
    USE=immqt emerge =x11-libs/qt-3.3.4
    That will rebuild the package.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •