Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Slow opengl in gentoo

    07:00.0 VGA compatible controller: nVidia Corporation NV45 [GeForce 6800 GTO] (rev a2)

    using x11-drivers/nvidia-drivers-100.14.19

    Available OpenGL implementations:
    [1] nvidia *

    xorg.conf :
    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoRenderExtension" "false"
    Option "RenderAccel" "true"
    Option "AllowGLXWithComposit" "true"

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24

    direct rendering: Yes
    server glx vendor string: NVIDIA Corporation
    server glx version string: 1.4
    server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer,

    use flags:
    USE="acpi alsa arts cairo cdr dbus directfb dvd dvdr dvdread eds emboss encode esd evo fam firefox gif gnome gpm gstreamer gtk hal jpeg kerberos ldap mad mikmod mp3 mpeg ogg opengl oss pdf png qt3 qt3support qt4 quicktime samba sdl spell svg tiff truetype v4l2 vorbis win32codecs unicode X xml xv"

    as guessed, compiz runs like crap, very choppy, steam won't even run anything, the apps just exit with no error. I'm at a loss as how to fix this issue..

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    NH, USA
    try upgrading to the newer driver see if that works better for you

    also try adding this to device section
    Option "XAANoOffscreenPixmaps" "true"
    and this to your screen
    Option "AddARGBGLXVisuals" "True"

  3. #3
    hmm, i tried those suggestions but still have the same results

  4. $spacer_open
  5. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Try the newest beta drivers. They aren't in portage, but you can put them in your local overlay by copying the ebuild (to your local overlay) and renaming it to the correct version number.

    x11-drivers/nvidia-drivers-169.07 -- The latest beta version.

    I haven't had any problems with opengl implementations on my gentoo boxes. I have an 8800GT and I have a 6800GTX and neither have problems.

    The relevant section of my xorg.conf (ignore the dual monitor stuff):
    Section "Device"
        Identifier  "Nvidia 8800GT0"
        Driver      "nvidia"
        BusID	"PCI:1:0:0"
        Option	"NVAGP"		"0"
        Option	"RenderAccel"	"true"
        Option	"AllowGLXWithComposite"	"true"
        Option      "backingstore" "true"
        Option   	"UseEdidDpi"   "false"
        Option	"CustomEDID"	"DFP-0:/root/sedid.bin; DFP-1:/root/ctedid.bin"
        Option   	"DPI"   "96 x 96"
        Option      "AddARGBGLXVisuals" "true"
        Option	"TwinViewOrientation"	"RightOf"
        Option	"HorizSync"	"DFP-0: 30-81;DFP-1: 31.5-80"
        Option	"VertRefresh"	"DFP-0: 56-75;DFP-1: 56-75"
        Option	"ConnectedMonitor"	"DFP-0,DFP-1"
    Also, seeing your /var/log/Xorg.0.log would help very much in diagnosing your problems.

    Code is Poetry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts