Find the answer to your Linux question:
Results 1 to 5 of 5
After some effort I have installed Gentoo from the liveCD purchased from Gentoo (I have dial-up networking). I tried to emerge Gnome, but it only got as far as this: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Can't emerge from liveCD...


    After some effort I have installed Gentoo from the liveCD purchased from Gentoo (I have dial-up networking). I tried to emerge Gnome, but it only got as far as this:
    Code:
    1090780627: Started emerge on: Jul 25, 2004 14:37:07
    1090780627:  *** emerge  gnome
    1090781115:  >>> emerge (1 of 136) dev-perl/XML-Parser-2.34 to /
    1090781115:  === (1 of 136) Cleaning (dev-perl/XML-Parser-2.34::/usr/portage/dev-perl/XML-Parser/XML-Parser-2.34.ebuild)
    1090781119:  === (1 of 136) Compiling/Merging (dev-perl/XML-Parser-2.34::/usr/portage/dev-perl/XML-Parser/XML-Parser-2.34.ebuild)
    1090781232:  === (1 of 136) Post-Build Cleaning (dev-perl/XML-Parser-2.34::/usr/portage/dev-perl/XML-Parser/XML-Parser-2.34.ebuild)
    1090781236:  >>> AUTOCLEAN: dev-perl/XML-Parser
    1090781236:  --- AUTOCLEAN: Nothing unmerged.
    1090781236:  ::: completed emerge (1 of 136) dev-perl/XML-Parser-2.34 to /
    1090781236:  >>> emerge (2 of 136) dev-util/intltool-0.30 to /
    1090781236:  === (2 of 136) Cleaning (dev-util/intltool-0.30::/usr/portage/dev-util/intltool/intltool-0.30.ebuild)
    1090781240:  === (2 of 136) Compiling/Merging (dev-util/intltool-0.30::/usr/portage/dev-util/intltool/intltool-0.30.ebuild)
    1090781307:  === (2 of 136) Post-Build Cleaning (dev-util/intltool-0.30::/usr/portage/dev-util/intltool/intltool-0.30.ebuild)
    1090781311:  >>> AUTOCLEAN: dev-util/intltool
    1090781311:  --- AUTOCLEAN: Nothing unmerged.
    1090781311:  ::: completed emerge (2 of 136) dev-util/intltool-0.30 to /
    1090781311:  >>> emerge (3 of 136) dev-util/pkgconfig-0.15.0 to /
    1090781311:  === (3 of 136) Cleaning (dev-util/pkgconfig-0.15.0::/usr/portage/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild)
    1090781314:  === (3 of 136) Compiling/Merging (dev-util/pkgconfig-0.15.0::/usr/portage/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild)
    1090781783:  === (3 of 136) Post-Build Cleaning (dev-util/pkgconfig-0.15.0::/usr/portage/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild)
    1090781786:  >>> AUTOCLEAN: dev-util/pkgconfig
    1090781786:  --- AUTOCLEAN: Nothing unmerged.
    1090781786:  ::: completed emerge (3 of 136) dev-util/pkgconfig-0.15.0 to /
    1090781786:  >>> emerge (4 of 136) gnome-base/gnome-mime-data-2.4.1 to /
    1090781786:  === (4 of 136) Cleaning (gnome-base/gnome-mime-data-2.4.1::/usr/portage/gnome-base/gnome-mime-data/gnome-mime-data-2.4.1.ebuild)
    1090781790:  === (4 of 136) Compiling/Merging (gnome-base/gnome-mime-data-2.4.1::/usr/portage/gnome-base/gnome-mime-data/gnome-mime-data-2.4.1.ebuild)
    1090781792:  *** terminating.
    The "Binary Packages Disc" was and is in the CD drive and mounted. There is plenty of room in my partitions as shown when I df each. If run "emerge gnome" again, there are multiple messages where it appears emerge is trying to connect to various ftp and http sites, all without success, since networking is not set-up. Each message (there are many) ends with
    Code:
    Resolving ftp.gnome.org... failed: Temporary failure in name resolution.
    Why would it look for an ftp site when the first three packages were apparently successfully found on the liveCD? And how can I redirect it or otherwise work through or around this?

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    As you did not include the _full_ emerge (and options used) command I will assume that you did not give the correct options. Reading the man page would give you this information:

    Code:
     --usepkg (-k)
                  Tells emerge to use binary packages (from $PKGDIR) if  they  are
                  available,  thus possibly avoiding some time-consuming compiles.
                  This  option  is  useful  for  CD  installs;  you   can   export
                  PKGDIR=/mnt/cdrom/packages  and  then  use  this  option to have
                  emerge "pull" binary packages from the CD in  order  to  satisfy
                  dependencies.
    
           --usepkgonly (-K)
                  Behaves  just  as  --usepkg  except  that  this will only emerge
                  binary packages.  All the binary packages must be  available  at
                  the  time of dependency calculation or emerge will simply abort.
    
           --verbose (-v)
                  Tell emerge to run in verbose mode.  Currently this flag  causes
                  emerge to print out GNU info errors, if any, and to show the USE
                  flags that will be used for each package when pretending.

  3. #3
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    basicaly, the livecd is looking for the files online still, checkout the gentoo handbook at www.gentoo.org under doc's to have portage look for the files on your cd.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Variant:

    Thanks for the reply. I tried that with this result:
    Code:
    localhost root # emerge -K /mnt/cdrom/gnome-base/ gnome
    Calculating dependencies
    emerge: there are no masked or unmasked ebuilds to satisfy "/mnt/cdrom/gnome-base".
    
    !!! Error calculating dependencies. Please correct.
    There are no USE flags in /etc/make.conf to over-ride the defaults in /etc/make.profile/make.defaults. Those in the latter follow:
    Code:
    USE="x86 oss apm arts avi berkdb crypt cups encode foomaticdb gdbm gif gpm gtk gtk2 imlib
    jpeg kde gnome libg++ libwww mad mikmod motif mpeg ncurses nls oggvorbis
    opengl pam pdflib png python qt quicktime readline sdl slang spell ssl
    svga tcpd truetype X xml2 xmms xv zlib"
    There are no files *ebuild on the x86 Binary Packages Disc but there are *.tbz2 including gnome-mime-data-2.4.1.tbz2 (that, with the .ebuild extension instead of .tbz2 is what kept coming up in the code listing of the first message in this thread.). There are beaucoup ebuilds in /usr/portage. Using these as the -K argument give same results as in code at the top of this message.

    Responses --verbose appreciated.

  5. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    It looks like you stumped the band, DrakeBasher. The answer is right in front of you. In the Gentoo installation instructions, a bit after where it says "Congratulations! Your Gentoo system is now ready."...no, skip over the part about finishing the setup on Macs. Oh, and skip the part about configuring for MIPS, yeah, skip that part and go way down to where it says "Optional: Install GRP Packages". Do this:
    Code:
    # export PKGDIR="/mnt/cdrom"
    # USE="bindist" emerge --usepkg gnome
    and, with luck, you will THEN pass through the door beyond which you can say: "et voila!" ...or whatever.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •