Find the answer to your Linux question:
Results 1 to 2 of 2
The title pretty much sums up the problem, if I press Ctrl + Alt + F1 (F2, F3, etc.), while X is running, nothing happens. The only way I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jan 2006
    Posts
    414

    Ctrl + Alt + F* doesn't do anything when X is running


    The title pretty much sums up the problem, if I press Ctrl + Alt + F1 (F2, F3, etc.), while X is running, nothing happens. The only way I can switch to tty1-6 is by opening a terminal and killing X.

    If I have a gnome-terminal open and press Ctrl + Alt + F1, it prints ;7P to the terminal window, P gets printed on xterm if it's open. That's the only sign the the keypresses are even being registered.

    Once X is stopped I can switch between tty's without problems.

    My desktop is made up of Fluxbox, kiba-dock, and xcompmgr (so transparency works), with ivman running as an automounter. Stopping any of these doesn't make any differance, likewise changing to a Gnome desktop doesn't change anything...

    I've got a custom Xmodmap to suit my Cherry Master Linux keyboard:
    Code:
     $ cat .Xmodmap 
    ! Internet-Keys (Back, Forward, Stop, Reload, Search)
    keycode 234 = XF86Back
    keycode 233 = XF86Forward
    keycode 232 = XF86Stop
    keycode 231 = XF86Reload
    keycode 122 = XF86Search
    ! Multimedia-Keys (Play/Pause, Stop, Back, Forward, Eject)
    keycode 162 = XF86AudioPlay
    keycode 164 = XF86AudioStop
    keycode 144 = XF86AudioPrev
    keycode 153 = XF86AudioNext
    keycode 204 = XF86Eject
    ! XPress-Keys left (Up, Down, Cut, Paste, Copy)
    keycode 220 = XF86ScrollUp
    keycode 143 = XF86ScrollDown
    keycode 188 = XF86Cut
    keycode 192 = XF86Paste
    keycode 248 = XF86Copy
    ! XPress-Keys right (List 1, List 2, List 3, Redo, Undo)
    keycode 159 = XF86Launch1
    keycode 151 = XF86Launch2
    keycode 171 = XF86Launch3
    keycode 138 = Redo
    keycode 135 = Undo
    ! Premium-Keys (Calculator, Email, Browser, On/Off)
    keycode 161 = XF86Calculator
    keycode 236 = XF86Mail
    keycode 130 = XF86HomePage
    keycode 199 = XF86LogOff
    ! Main-Keys (-, +, Mute, Media-Player)
    keycode 174 = XF86AudioLowerVolume
    keycode 176 = XF86AudioRaiseVolume
    keycode 160 = XF86AudioMute
    keycode 129 = XF86AudioMedia
    ! @-Key
    keycode 116 = at
    and likewise a custom setup in .fluxbox/keys:
    Code:
     $ cat .fluxbox/keys 
    OnDesktop Mouse1 :HideMenus
    OnDesktop Mouse2 :WorkspaceMenu
    OnDesktop Mouse3 :RootMenu
    OnDesktop Mouse4 :NextWorkspace
    OnDesktop Mouse5 :PrevWorkspace
    
    Control F2 :ExecCommand fbrun -nearmouse
    
    Mod1 Tab :NextWindow
    Mod1 Shift Tab :PrevWindow
    Mod1 F1 :Workspace 1
    Mod1 F2 :Workspace 2
    Mod1 F3 :Workspace 3
    Mod1 F4 :Workspace 4
    Mod1 F5 :Workspace 5
    Mod1 F6 :Workspace 6
    Mod1 F7 :Workspace 7
    Mod1 F8 :Workspace 8
    Mod1 F9 :Workspace 9
    Mod1 F10 :Workspace 10
    Mod1 F11 :Workspace 11
    Mod1 F12 :Workspace 12
    
    None XF86Launch1 :Workspace 1
    None XF86Launch2 :Workspace 2
    None XF86Launch3 :Workspace 3
    !
    None XF86AudioPrev :ExecCommand audacious--rew
    None XF86AudioPlay :ExecCommand audacious --play-pause
    None XF86AudioNext :ExecCommand audacious --fwd
    None XF86AudioStop :ExecCommand audacious --stop
    None XF86Eject :ExecCommand audacious -j
    !
    None XF86AudioLowerVolume :ExecCommand amixer sset PCM 2-
    None XF86AudioMute :ExecCommand amixer sset "Audigy Analog/Digital Output Jack" toggle
    None XF86AudioRaiseVolume :ExecCommand amixer sset PCM 2+
    None XF86AudioMedia :ExecCommand totem
    !
    None XF86Calculator :ExecCommand gcalctool
    None XF86Mail :ExecCommand /usr/bin/evolution
    None XF86HomePage :ExecCommand /usr/bin/firefox
    Disabling the Xmodmap, and/or fluxbox keys makes no difference. Neither get's called in Gnome anyway, where the problem still exists...

    So, any ideas? I don't really know where to start on this.

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    All fixed, I just commented out:
    Code:
    Option         "XkbVariant" "nodeadkeys"
    in my xorg.conf then restarted X and I can switch consoles no problem. Plus all my multimedia/special keys still seem to be working, so all is well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •