Find the answer to your Linux question:
Results 1 to 6 of 6
no matter how i try i cannot get the clock right on my desktop. it is currently about 7:46 in Pennsylvania. thats with daylight savings. but heres my /etc/conf.d/clock config ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Location
    127.0.0.1
    Posts
    29

    the clock in fluxbox


    no matter how i try i cannot get the clock right on my desktop. it is currently about 7:46 in Pennsylvania. thats with daylight savings. but heres my /etc/conf.d/clock config i hope you can tell me the error of my ways.

    Code:
    # /etc/conf.d/clock
    
    # Set CLOCK to "UTC" if your system clock is set to UTC (also known as
    # Greenwich Mean Time).  If your clock is set to the local time, then 
    # set CLOCK to "local".  Note that if you dual boot with Windows, then 
    # you should set it to "local".
    
    CLOCK="local"
    
    # Select the proper timezone.  For valid values, peek inside of the
    # /usr/share/zoneinfo/ directory.  For example, some common values are
    # "America/New_York" or "EST5EDT" or "Europe/Berlin".  If you want to
    # manage /etc/localtime yourself, set this to "".
    
    TIMEZONE="America/New_York"
    
    # If you wish to pass any other arguments to hwclock during bootup, 
    # you may do so here.
    
    CLOCK_OPTS=""
    
    # If you want to set the Hardware Clock to the current System Time 
    # during shutdown, then say "yes" here.
    
    CLOCK_SYSTOHC="no"
    
    
    ### ALPHA SPECIFIC OPTIONS ###
    
    # If your alpha uses the SRM console, set this to "yes".
    SRM="no"
    
    # If your alpha uses the ARC console, set this to "yes".
    ARC="no"
    thanks in advance!!!! =)

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    Have you tried setting the clock to utc?

    Code:
    CLOCK="UTC"

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Location
    127.0.0.1
    Posts
    29
    well i changed it back to UTC and now it is just one hour off. is there some package that would correct this for daylight savings time?

    thanks!

  4. #4
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Quote Originally Posted by Tralfas View Post
    well i changed it back to UTC and now it is just one hour off. is there some package that would correct this for daylight savings time?

    thanks!
    On most operating systems I've worked on, the computer (BIOS) clock itself is set forward an hour to compensate for DST. I don't know if you're dual- or triple-booting with some other operating system, but I'd suggest simply moving the computer clock ahead one hour.

  5. #5
    Just Joined!
    Join Date
    Jan 2008
    Location
    127.0.0.1
    Posts
    29
    i changed the clock and that did the trick thanks!!!

    now i have some more questions mostly about some custom stuff in fluxbox.

    how do you make terminal look like it does on the left and what is the app on the left of the screen?


  6. #6
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    You need X Composite Manager. While Fluxbox can do a sort of "pseudo-transparency" by itself, the resulsts don't tend to look too great. Here's a Gentoo guide for setting up transparency in Xorg:
    Xorg X11 and Transparency - Gentoo Linux Wiki

    Once you've set it up, you should be able to adjust the transparency of each window under its preferences.

    As for the app on the far left of the screen, that's some sort of widget.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •