Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Slow X Performance

    Applications seem to take a long time to start when using them in the X window environment. The time it takes them to start seems to be dependent on the size of the program ( firefox takes about 7-15 seconds, whereas terminal only takes 1 second )
    It affects both twm and gnome.

    If i start a terminal window and run firefox, i get:
    cwin@cwin cwin $ firefox
    No running windows found
    < and it waits here for about 7-15 seconds minimum >
    < firefox appears >
    Also to clarify, it does not just affect firefox.

    Once the application is running its fine. Windows start quickly, it browses with speed, no issues whatsoever, its just the initial starting that takes ages.

    I'm on a 2.8GHz P4 so i dont think my processor is an issue. It's ran quicker using slackware and my 500MHz using redhat ran quicker too.

    Ive tried both the gentoo-dev-sources and development-sources

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Lat: 39:03:51N Lon: 77:14:37W
    Xserver performance is not always directly linked to processor speed, if you dont have hardware acceleration enabled, then you will have significantly slower graphical startup times. Try installing the recommened driver for your graphics card and then look for a performance increase. In general starting a program will take longer than starting a new window of a program, but that time on those specs makes software graphical acceleration a likely culprit.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Try looking into 'prelinking'. Binary packaged distro's are almost always prelinked, wich can imply a great boost on loading speed. There's a guide to prelinking in the gentoo user docs, try it, maybe it will help you?

    \\Edit: btw, I have the problem too. Loading times of +- 9 seconds on firefox. Terminals come up instantly, so it's just the big memory size of firefox (and my small 256Mb ) that cause swapping when starting firefox.
    Just a thought

  4. $spacer_open
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Stockholm, Sweden
    In addition to those points its worth having somone check your /etc/make.conf it could be that your settings can be tweaked to help things.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts