Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
As a continuation of my scsi saga. I got the issue of loading the modules squared away, but noe it tells me the Block device /dev/sda3 is not a valid ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396

    mounting /dev/sda3 as root device problems


    As a continuation of my scsi saga. I got the issue of loading the modules squared away, but noe it tells me the Block device /dev/sda3 is not a valid root device...
    The root block device is unspecified or not detected. I'm guessing so problem detecting my HD's but its really odd bc im booting from one.... Could it be a problem with the FS, my boot is ext2 and the sda3 is rieserfs, but its the genkernel, so it should have support for all of them. Any post would be helpful.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  2. #2
    Content Team tylerwylie's Avatar
    Join Date
    Apr 2004
    Posts
    120
    Make sure you have reiserfs support in your genkernel, I forgot the command, like genkernel make or something to that effect, it is in the new documentation so go check that out.

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2
    Same issue here, using ext3 all the way, running under vmware 4.5. Tried both scsi and ide emulation installs, no dice. I can boot of the live cd and mount everything manually just fine, but when I try to boot off the hard drive it boots up, grub works, then it croaks right about the time it tries to load the / partition. Any help will be greatly apreaciated, all searching has been in vein.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    SCSI disk modules required

    I had this same problem. I solved it by making the scsi modules built into the kernel, NOT modular. You must include scsi_disk (sd) and scsi_generic (sg) or it still will not boot. I also had to increase the size of the initrd disk to 8192 before compiling.
    genkernel --menuconfig --no-mrproper --no-clean all will allow you to keep your existing configuration, just make sure all the stuff I mentioned above has an asterisk in front of them instead of an "M". All of it is found under drivers/scsi/ and drivers/scsi/low level drivers.

    PK

  6. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Got it working..

    Crap.. sorry for not following up, I fixed it a couple days after posting. I had to go in and enable Buslogic scsi drivers in the kernel to get the thing working under vmware. After I set up all the correct options, it was cake from there!
    As pksings said, do not make the scsi drivers modular!

  7. #6
    klm
    klm is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    Also got it working...

    Was having the same problem getting my gentoo guest going, and pksing's solution worked for me, too. I happen to be using a beta VMWare 5.0, so thought it might be worth speaking up also. (I found the forum via google, and want to increase the chances that other's with this problem can, too.)

    ken

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    Same Problem here

    Hi there.

    I have the same problem when instlaling 2005.1 on VM Ware.

    I fdisked /dev/sda to

    32M sda1, 512M sda2, Rest sda3

    Then i did "genkernel --menuconfig --udev all" and chanded SG to be in the kernel. SD where allready directly in the kernel.

    Also ramdisk is 8192.

    Still the error occurs when trying to boot into the new installation.

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1
    I'm experiencing the same thing as believe. Looks like our configuration is pretty much alike. I did what pksings suggested and did the genkernel --menuconfig --no-mrproper --no-clean all, and making sure scsi support was built into the kernel. I went so far as to include all the scsi drivers just in case (which made genkernel run forever), and still, no go. The documentation says to add the "doscsi" option as a kernel option. How do you do that? Do you simply add that to the grub.conf file in the kernel command?

    Please help.

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    The documentation says to add the "doscsi" option as a kernel option. How do you do that? Do you simply add that to the grub.conf file in the kernel command?
    Yes, just after the kernel statement.

    kernel=.... init=/linuxrc real_root=/dev/sda3 doscsi

  11. #10
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    Same problem - solved

    I had the same problem, with /dev/sda3 being an invalid for root. After reading the above suggestions, I was discouraged to see that I was compiling all scsi into kernel and "doscsi" was in my kernel options line.

    Then I made two changes. First, I reran genkernel with --udev as anohter command line option, in addition to the options shown in earlier posts. I also moved the "doscsi" immediately after the real_root kernel option. Probably the rebuilt kernel made the difference, but regardless, it worked after doing both.

    Thanks from a lurker for sending me in the right direction.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •