Find the answer to your Linux question:
Results 1 to 4 of 4
Alright, so I took it upon myself to try a gentoo install, and so far, i've ran into some problems, and restarted the install, and whatnot, but so far i'd ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Seattle, WA or Lewisburg, PA. Depending on time of year.
    Posts
    37

    problem setting up xfree... libxkbfile.so.1 not present


    Alright, so I took it upon myself to try a gentoo install, and so far, i've ran into some problems, and restarted the install, and whatnot, but so far i'd say so good, more or less.

    Anyway, my problem is that after emerging xfree, nvidia-glx, and gnome.. and setting them up as properly as I could... I can't get startx to work with gnome... that is, without gnome, i could try startx and it would give me a mouse, and I couldmove it and whatnot... then with Gnome, it says that xkbcomp has a missing library, (i'm not currently at the comp...). I thought that emerge took care of everything I would need, so I'm getting partly frustrated about what is happening with my install...it took me long enough just to get the mouse to work...

    I haven't been able to find even which package xkbcomp would be part of... anyone run into this problem or know how to fix it? I haven't been able to find it anywhere online...

    thanks


    (As a side problem, it seems like gentoo supports xorg, wheras the nvidia-glx requires xfree libraries, could this be the problem in any way?)

  2. #2
    Content Team tylerwylie's Avatar
    Join Date
    Apr 2004
    Posts
    120
    About 30 seconds on google.com would be able to solve this problem, seems like you enabled xkb options in your /etc/X11/XF86Config file. rerun xf86config and disable xkb and then try it.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    Seattle, WA or Lewisburg, PA. Depending on time of year.
    Posts
    37
    so i got tired of looking for it, since I couldn't find the solution... didn't occur to me that xkb was an option I set, although I looked at that damn file for a while. Thanks for the heads up in the future!

  4. #4
    Content Team tylerwylie's Avatar
    Join Date
    Apr 2004
    Posts
    120
    So it worked, yay.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •