Find the answer to your Linux question:
Results 1 to 3 of 3
A Linux newbie's attempt to install Gentoo on and outdated machine (don't try this at home): Is it even possible to install the Gentoo 2008.0 with the minimal CD through ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Larry_the_Cow's Avatar
    Join Date
    Jul 2008
    Location
    Sarajevo, Bosnia
    Posts
    2

    Question Gentoo Installation using minimal CD through WPA network


    A Linux newbie's attempt to install Gentoo on and outdated machine (don't try this at home):
    Is it even possible to install the Gentoo 2008.0 with the minimal CD through a WPA(-PSK) connection? The Gentoo Handbook(x86) doesn't even mention WPA until the fourth section of Chapter 4(Wireless Networking), still, I can't imagine that Gentoo doesn't have the capabilities to connect to WPA until installed fully installed. Anyway I'm trying to install Gentoo on an old Toshiba Satellite laptop with:
    Processor:Celeron 430.4 MHZ
    RAM: 64mb
    HDD: approx 6GB
    Chipset: Intel 1440BX
    It meets minimum requirements for the Minimal CD install but not for the LiveCD (with it nice new point-and-click GUI installer). I'm trying to connect to the net via the Linksys WUSB54G v4 network adapter (through a USB 1.0 port). Gentoo recognizes it immediately as wlan0, and after I run net-setup it will display(using iwconfig) the correct ESSID and access point, but, both "Link Quality" and "Signal Level" appear at zero and a ping returns "unknown host". Also the "Encryption key" displays 6 sequences of characters(a combination of letters and numbers) each 4 characters in length separated by dashes(-). Apparently it thinks the passphrase I enter is a WEP key even asking: "Are you entering you WEP key in HEX or ASCII?"
    But if I try to configure my network manually as described in the Gentoo Handbook under "Using ifconfig And route" it returns: "bash: ${192.168.1.1} bad substitution" (192.168.1.1 is the default IP address for Linksys routers) On a side note: I have tested the Wireless Adapter with a different computer under WinXP and it worked fine.
    Anyway I know that the standard tool for WPA networking in Linux is wpa_supplicant with happens to be on the minimal CD but won't anything except repeat itself again, unless you try to configure it with: -c/etc/wpa_supplicant.conf in which case it returns "failed to reed or parse configuration '/etc/wpa_supplicant.conf' so I'm kinda at a loss there, though that looks like my best bet. I tryed something called wpa_passphrase which has you input the ssid and passphrase and then displays:
    ssid="[myfakenetworkname]"
    #psk="[myfakepassword]"
    psk= (a really really long string of letters and numbers)
    Anyway after doing that, iwconfig shows the Encryption key in the same format as previously described but with 19 groups of characters instead of only 6 so apparently I'm making some progress but not more than that. Both Link Quality and Signal level still display 0 and a ping still returns "unknown host". The last the I've tried is wpa_cli but after displaying the version number (v0.5.7) and copyright and license info it says: "Could not connect to wpa_supplicant - re-trying" after which is displayed a blinking text input underscore thingy and it just sits there until I have to force the computer off. So is it possible to connect to a WPA network via minimal CD and if so how? Help would be much appreciated as this is my second Linux install (I put Debian on the same box about a week ago)

    -Cheers, Larry_the_Cow (official Gentoo Mascot)

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Location
    Sweden, Earth, Milky way
    Posts
    10
    Hi.
    Try this:
    Code:
    wpa_passphrase [your essid] [yourpassphrase] >> /etc/wpa_supplicant.conf
    wpa_supplicant -c /etc/wpa_supplicant.conf -i wlan0 [-B] (the -B is for forking the process to background. Don't do that until you have seen that it works)
    dhcpcd -d wlan0

  3. #3
    Just Joined! Larry_the_Cow's Avatar
    Join Date
    Jul 2008
    Location
    Sarajevo, Bosnia
    Posts
    2
    First of all, thank you so much for taking the time to answer, unfortunately I'm still unable to connect, when I enter the first line:
    wpa_passphrase [mynetworkssid] [mypassphrase] >> /etc/wpa_supplicant.conf
    it apparently works fine, but when I enter the second line:
    wpa_supplicant -c /etc/wpa_supplicant.conf -i wlan0 [-B]
    it returns:
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x1 - ioctl[SIOCSIWAUTH]: Resource temporarily unavailable
    You said don't fork the process to the background until you know it works so I did it without the [-B] and then just the -B without the brackets: same output except without the "Resource temporarily unavailable" thing.
    After that I tryed the debugging thing as described on linux.die.net/man/8/wpa_supplicant:
    wpa_supplicant -c/etc/wpa_supplicant.conf -iwlan0 -d
    but it gave me:

    No Suitable AP found
    setting scan request 5 sec 0 usec
    Starting AP scan
    RTMNEWLINK: operstate = 0 ifi_flags=0x1003 ([UP])
    wireless event: cmd = 0x8b19 len 8
    Received 250 bytes of scan results
    Scan results:1
    Selecting BSS from priority group 0
    0:00:16:b6:33:dd:e2 ssid='mynetworkname' wpa_ie_len=26 rsn_ie_len=0 caps 0x11
    Skip-SSID
    (it then repeated those those lines until I had to force it off.)
    So I still can't connect. How to set this up should really be in the Handbook.
    The reason I have taken so long is that for some reason 4 out of 5 times Gentoo freezes as it's trying to unpack the firmware to run my processor (Celoron 430MHz)
    If anyone has any ideas on how to fix either of these problems please post them.
    -Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •