Find the answer to your Linux question:
Results 1 to 4 of 4
I set up dual booting with gentoo / xp on my 320gb sata drive. Later on I added a 1tb sata drive for storage to the system. I booted to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    2

    Need help with my storage drive


    I set up dual booting with gentoo / xp on my 320gb sata drive. Later on I added a 1tb sata drive for storage to the system. I booted to XP and formatted it there in ntfs, since I'm a newbie to Linux and didn't want to goof it up. The drive was working fine in xp and I started putting junk on it. But I had goofed anyway when I put the drive in a lower sata port than my boot drive. When I edited it into fstab and tried booting into gentoo I got a looping error, don't remember specifics. Looking back, it was telling me the first drive it found wasn't set up to boot but I didn't know that. I rebooted and tried a few more times but it didn't work, so I booted back to XP and both drives were still working fine.

    A day later I rebooted and went afk, forgot I had grub set to wait 30 seconds and then boot gentoo. This let the error loop till its end where my PC froze. When I rebooted my bios wasn't recognizing the 1tb drive, and still isn't. I've tried resetting my cmos, no change. The error message in the boot log is Comreset failed, errno=-16. Google turned up a few bugs, but nothing like my situation.

    I have a feeling it's not a dead drive, since it would be a hundred to one shot it would fail at that exact moment. What would Gentoo do to a drive if it wasn't set to boot from that drive, and how do I reverse it?

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,010
    Quote Originally Posted by baelon View Post
    When I rebooted my bios wasn't recognizing the 1tb drive, and still isn't.
    If bios isn't recognising your hardrive I would start out by unplugging hardrive and replug it in with computer powered down. Then I would reset bios to defaults settings and save and reboot and see what happens.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    I'd plug off your power cable, take off the small battery from your mother board, unplug and re-plug your hd, wait a few seconds, plug both things into their respective places again and try.

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    2
    Thanks for the advice, but it's a no-go. I'm going to RMA the drive. I'm awfully suspicious concerning the timing of the drive's death, but whatever.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •