Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 40
belikeyeshua, I did gentoo 3 times in a virtualbox on my windows vista. (you'll need at least 5 gigs of space for the portage and kernel stuff...) VirtualBox That helped ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2006
    Posts
    26

    belikeyeshua, I did gentoo 3 times in a virtualbox on my windows vista. (you'll need at least 5 gigs of space for the portage and kernel stuff...)

    VirtualBox

    That helped me because I didn't want to take the chance of wiping a 160gb drive that I couldn't actually get gentoo on.

    Something that caught me up, when I had to recompile my kernel and set it again I found that the boot swap is where you place your ACTUAL kernel program, and grub.conf.

    So basically your grub.conf and kernel are seperate from your root . But when I recompiled my kernel I dropped it into /boot/ and nothing worked. That was because I didn't mount the boot. I then mounted the boot and copied the kernel over, then saw grub.conf and set it to the new kernel name (renaming the old kernel)

    Hope my mistake helps you understand a little better.

  2. #12
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38

    Exclamation

    Any help would be appreciated. I still do not know how to get it working.

    Here is the /boot/grub/grub.conf file:

    Which listing to boot as default. 0 is the first, 1 the second etc.
    default 0
    # How many seconds to wait before the default listing is booted.
    timeout 30
    #splashimage=(hd0,0)/boot/grub/splash.xpm.gz

    title Gentoo Linux 2.6.25-r7
    # Partition where the kernel image (or operating system) is located
    root (hd0,0)
    kernel /boot/kernel-2.6.25-gentoo-r7 root=/dev/hda3

    title Gentoo Linux 2.6.250r7 (rescue)
    # Partition where the kernel image (or operating system) is located
    root (hd0,0)
    kernel /boot/kernel-2.6.25-gentoo-r7 root=/dev/hda3 init=/bin/bb

    When typing in Kernel (hd0,0)/kernel-2.6.25-gentoo-r7 root=/dev/hda3, it says something like no file or something like that.... help?

  3. #13
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    When I try to boot my system, it says that I must load kernel first... I thought for sure that I had a 2.6.25-gentoo-r7... or that was what it said after I did emerge gentoo-sources.

    Help?

    If I cannot get gentoo booted up, I am going back to Xubuntu with compiz fusion... this is crazy.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    What is happening is exactly what I said earlier. Your drive geometry has changed from the livecd to your installed grub. You will have to load the kernel via the grub command line, and resinstall grub when you get booted. You will probably also have to edit grub.conf after the fact.

    Type "help" at the grub prompt to give you the commands that grub accepts. Then you will want to set your "root" to wherever grub is installed, set your "kernel" to whatever your kernel is, and "boot" it.

    It is the same as using grub, you are just doing from the command line.

    Also, I know you are using hd*, but the kernel may call them sd*. It won't matter what kind you actually have, the new drivers in the kernel call ALL hard drives sd*, so if you have selected the new driver in the kernel, you will have to put in sd*.

    Grub only accepts hd*,* though, no matter if it is hd* or sd*. Confusing, huh?

    Linux User #376741
    Code is Poetry

  6. #15
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    tired a few things...

    I notice that when I type in setup (hd0)... it comes back with an error, I forget what it said.

    I tried to configure the /boot/grub/grub.conf to say dev/sda3 instead of hda3... but that made it worse off so I changed it back to hda

  7. #16
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    Maybe it might be good if I reinstall grub...?

    Also, I tried to use LILO instead of GRUB, but it seems hard to configure... too hard. Maybe if I do some more research I can do it. The problem also, is that every time I install something I cannot copy and paste it as I have not connected it to another box.

  8. #17
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    Or will LILO have the same problem as grub? I think I prefer the look and feel of grub but I suppose it does not matter since the computer will be on more than it will be off.

  9. #18
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    I would stick with Grub rather than LILO ... but it's up to you.

    Can you boot from a live CD, and post the output of
    Code:
    fdisk -l
    , mount the boot partition and post ls output of boot partition.

    When you try to start the system what errors do you get and are they error message from Grub or a kernel panic?

  10. #19
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    I will find it out soon, when I get the time.

    Yes, I like grub better than lilo, IF (and only if) it actually works.

  11. #20
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    ls /boot says:
    boot grub lost+found

    setup (hd0) says:
    Error 31: file is not sector aligned. The only thing that failed in the setup was install /boot/grub/stage1 (hd0) 1+16 p (hd0,0) /boot/grub/stage2 /boot/grub/menu.lst

    When I type in kernel (hd0,0)/kernel-2.6.25-gentoo-r7, I get this:
    Errot 15: file not found

    I did edit the /boot/grub/grub.conf file as I found out that the kernel was listed as /kernel-2.6.25-gentoo-r7 when it was supposed to be /boot/kernel-2.6.25...

    Now, when I reboot without the CD in teh drive, I get:
    Grub Loading Stage 1.5

    It does that for forever.

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •