Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 40
I have installed Gentoo using a stage three tarball literally SEVERAL times in a row with the SAME results EVERY time. I have followed the handbook religiously and still it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38

    Exclamation HELP! Gentoo Linux Install PROBLEM with grub.


    I have installed Gentoo using a stage three tarball literally SEVERAL times in a row with the SAME results EVERY time.

    I have followed the handbook religiously and still it does not work, at all. What happens is after I restart, it loads to grub and does nothing. I can type in some minimal commands but I get stuff like filesystem not specified, must load kernel first, and the like. I did edit my boot/grub/grub.conf file to include my kernel (kernel-2.6.25-gentoo-r7), I have tried several different things with the SAME results... NOTHING.

    I am installing on a Dell Inspiron 8200 Laptop. 1.8Ghz, 60GB 6400RPM Hard Drive, 1GB 266Mhz RAM...

    Any help would be appreciated. I am only going to give Gentoo ONE MORE try, then I am going back to the really cool xubuntu with xfce and compiz fusion, though not as fast as gentoo.

    Is there instructions on the internet that is accurate, or more accurate? its absolutely crazy, I have been without a computer for four days not because of this. I have been able to use links while installing gentoo though. Its a FAST black and white web browser

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Post the contents of grub.conf and /etc/fstab files. Post the output of fdisk -l and ls /boot commands too.
    Code:
    ls /boot
    cat /etc/fstab
    cat /boot/grub/grub.conf 
    fdisk -l
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    The problem is that the livecd is probably reading your harddrive as sda and your base install is probably actually hda, or vice versa.

    You can boot from grub by setting root from the prompt it gives you and loading the kernel. Then you have to boot said kernel, and it should boot up correctly, allowing you to edit your grub.conf. It has happened to me since they have changed the drivers in the kernel and made everything sd*.

    One thing that will help though, is make sure you are using the newer drivers in the kernel instead of the deprecated one that uses hd*.

    Oh, and are you using the handbook to install gentoo? Or one of the "installers"?

    Linux User #376741
    Code is Poetry

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    Gruven,

    How exactly do I do that??

    Yes, my hard drive is a HDA not SDA, so the boot drive reads /dev/hda1.

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    I am using the x86 handbook.

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    I ended up wiping out the Hard Drive, planning on installing another OS... I am going to give gentoo ONE more chance, as I do not have the time for any more.

    That said, how can I install it so that I will be using a windows environment like xfce, and not have any grub problems???

    Again, I have a HDA hard drive, not SDA. The current kernel is Kernel-2.6.25-gentoo-r7. This is what I put in the grub file.

  7. #7
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I know you have a IDE (hd*) hard drive, but the newer kernels recognize them as sd* because of the drivers in the kernel.

    When I installed gentoo, the livecd recognized my 3 hard drives totally different than the actual install did, so I had to install gentoo, then when it tells you to reboot, boot from the livecd grub, edit the grub menu, and boot from the hard drive like that. Then, I had to reinstall grub in the new environment and it worked.

    At the grub prompt, you can type "help" and it will list the commands you can use in grub.

    I would almost bet that is your problem. It isn't hard to fix, but if you have never done it before, it can be intimidating and frustrating.

    Linux User #376741
    Code is Poetry

  8. #8
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    I do have quite a bit of linux experience, by now. I used Xubuntu recently with compiz fusion... it was nice and fast but not as fast as I would of wanted it to be. I really liked it.

    I would like to get gentoo working but my only gentoo experience is that it does not install right (for me).

    So, please tell me exactly what I have to do, and how, as with installing grub correctly and such.

    God bless!

    ~Shawn

  9. #9
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    if it means anything at all, it should be said that my hard drive is a 60GB Hitatchi 6400RPM IDE hard drive, on my dell inpiron 8200 laptop, and it uses a adapter that converts it to SCSI. This is the way it was when I got it.

    What i mean, is the motherboard is SCSI but the hard drive is IDE, using the adapter that came with it.

    But, I agree.... it is very frustrating, having to install several times with the same results.

  10. #10
    Just Joined!
    Join Date
    Sep 2008
    Posts
    38
    I am going to try again...

    I JUST thought about this, when I partitioned the hard drive, I was in a hurry and accidently set the boot drive as hda1, the root as hda2 and the swap as hda3... then I think I mounted the swap drive instead of the root drive and that was also what I specified in the grub file.

    Dear! I will try again.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •