Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi everybody, greetings from Guatemala, I have installed Gentoo 2008.0 with de "module selection method" and I have NO sound in my laptop. My laptop is an Acer TravelMate 2430, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    28

    Unhappy I have no sound with my SiS AC97 :(


    Hi everybody, greetings from Guatemala, I have installed Gentoo 2008.0 with de "module selection method" and I have NO sound in my laptop.

    My laptop is an Acer TravelMate 2430, this is the info about my soundcard: (gived by lspci):

    00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)

    And that's it...then in the Kernel Configuration (Device Drivers->Sound->Pci) I have selected the following driver:
    Intel/SiS/Nvidia/AMD/Ali AC97 Controller as a Module

    The name of the module is SND_AC97_CODEC.

    but when I try to load it with de "modprobe" says that is no driver...mmm...anyway...I read all the doc about ALSA in Gentoo official site and when I run #alsaconfig my cards is there and ALSA configures it (obviously this is not happening) because when I run the "alsamixer" it shows a "dummy" name in the Cards name field...

    The only that loads in the begginig is the intel-snd-1X0 or something like that, but There is NO sound instead...

    I have already add the user to the audio group too, everything was compiled with ALSA support too...

    It's really frustrating really, because everythings looks normal but there is no sound,
    I hope you can help me...

    Thanks guys, see ya later

  2. #2
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    What desktop environment are you using? I ask because the different DE's have different ways of handling sound. One uses pulseaudio or esd (and gstreamer), one uses phonon which handles multiple backends, and others use just plain alsa.

    I would suggest that if you ever install Gentoo again, use the handbook method instead of the automatic installer. You learn essential skills needed to maintain your Gentoo installation while doing the manual handbook install.

    Linux User #376741
    Code is Poetry

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    28
    Hey, thanks for answer so fast ....

    mmm...actually I am running KDE 3.5.8 with alsa support, and yep I install my Gentoo with the handbook, and install kmix but there is a card there called "AC 97" but I change the values and nothing happens

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Do you have "alsa" in your USE flags?

    KDE3 uses arts as its sound manager, and arts sucks. I usually build kde3 without arts support (-arts) and use /usr/bin/play as my sound player (part of the "sox" package).

    That may be too much for you to handle, as I am not familiar with your experience in linux, but it sounds much better.

    As for the module for your sound card, it will be called "snd-intel8x0" and if you built it as a module, you can run "alsaconf" and have it append whatever modules it needs to your module autoload file. Make sure when you are done, to set alsasound load at boot: "rc-update add alsasound boot" and that will take care of loading alsa for you.

    Also, run "alsamixer" and unmute your channels if you haven't done so already.

    If all of that still doesn't work, we will proceed from there. I use KDE4, so I may not be much help, but I will help where I can.

    Linux User #376741
    Code is Poetry

  6. #5
    Just Joined!
    Join Date
    Mar 2009
    Posts
    28
    Thanks for the help, actually I can load the module, run alsaconfig and everything seems ok because it hears a little "chic" from the speackers, I also set to "0" to the "dummy" inteface values, but my card not appears in the alsamixer, and there is no sound.

  7. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    What program exactly are you using to play sound? You have to turn the sound effects on in the kde settings to play event sounds, and if you are using something like amarok, it has different settings in it too.

    Linux User #376741
    Code is Poetry

  8. #7
    Just Joined!
    Join Date
    Mar 2009
    Posts
    28
    The "Enable Sound System" es activated in the KDE control center, but when I press "Test Sound" there is no sound, not in speakers or headphones, in Amarok there is no sound either, i want to play a .mp3 file and plays it without problems but I can hear anything ...I don't know what happens...:'(

  9. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Have you started alsasound? "/etc/init.d/alsasound start"

    Do you have the "arts" use flag enabled?

    I really don't know what else it could be, as most of the time sound just works for me with kde because I don't use arts at all. I use sox (/usr/bin/play) as an external player, and disable the sound system completely.

    If you want to try that, then we can.

    Linux User #376741
    Code is Poetry

  10. #9
    Just Joined!
    Join Date
    Mar 2009
    Posts
    28
    yep, the arts flag is enabled, the alsasound service is running, I don't know if the "arts" flag is causing some error...

    Hey, thanks for your time (Y)

  11. #10
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Well, all looks good if you have followed the guides, and enabled all of the flags.

    I did have an sis chipset once and have built Gentoo on it with kde, but like I said before, I didn't use arts at all, but you should still be getting some sound.

    Does the application think it is playing sound? I know sometimes that it will say it can't find the device or some other error. If it thinks it is playing the sound, make sure (which this is just a precaution, because I am sure you have done it) that you have your sound turned up on your speakers.

    Also, in kmix, enable other things and turn the volume up on them. My computer has the snd-hda-intel chipset and I can control my sound on three different sliders (master, front, pcm). Make sure and try different things in kmix.

    That is about all I can do to help unless you want to disable arts entirely, but you should be getting sound even through arts.

    Linux User #376741
    Code is Poetry

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •