Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Hello I have a problem with my mouse/keyboard in KDE/Gnome and Xfce or a plian X-server. The problem is that my mouse and keyboard freezes in the GUI, but i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    13

    Thumbs up [SOLVED] Gentoo USB Mouse/Keyboard freeze ind GUI


    Hello I have a problem with my mouse/keyboard in KDE/Gnome and Xfce or a plian X-server. The problem is that my mouse and keyboard freezes in the GUI, but i have no problem when I'm in the console - I have both the mouse and the keyboard running, no problem there. I alwasys reboots into console.
    (and I also kill my gpm everytime I think I have corrected the problem and wants to start the GUI but no they still freeze every fu.. time....) the only way to get out of one of the GUI is to take the power-core. and reboot again.

    I'm sittin with a:
    C2D Mobile T5600
    Intel i945G chipset(and onboard gfx)
    Logitech S510 Cordless keyboard and mouse
    (I have no PS/2 port on this PC only USB)


    and when I try to make a cat to /dev/input/mice or mouse1 i get a lot of grap txt os i know it is working my mouse in console but apparently not in any GUI help ?

    my conf's look like this:
    make.conf ->
    USE="acpi apache2 apm berkdb cairo caps cdr css cups curl curlwrappers dbus dri dvd fbcon ftp firefox gdbm geoip gif hal hddtemp java jpeg kde ldap libnotify lirc lm_sensors matroska mmap nls opengl pdf png python qt3 qt4 rdesktop samba sdl smp snmp sockets sse sse2 ssl svg svga syslog tiff truetype truetype-fonts tryetype type1-fonts usb unicode vcd vhosts vnc vorbis X xv xml xinetd x264 zlib win32codec wmf -gtk -gnome"
    GENTOO_MIRRORS="ftp://ftp.klid.dk/gentoo/"
    SYNC="rsync://rsync.euopre.gentoo.org/gentoo-portage"
    MAKEOPTS="-j3"
    VIDEO_CARDS="intel fbdev glint mach64 vesa wmvare i810"
    INPUT_DEVICES="endev keyboard mouse"
    FEATURES="sandbox ccache"
    CCACHE_DIR="/var/tmp/ccache"
    AUTOCLEAN="yes"
    LINGUAS="dk"

    modules.autoload/kernel-2.6 ->
    e1000
    processor
    i810fb
    video
    ahci
    freq_table
    intelfb
    usbcore
    output
    input_polldev


    fstab->(video resolution)
    vga=0x31B video=vesafb:mtrr:3,ywrap


    Xorg.conf->

    Section "ServerLayout"
    Identifier ""X.org Configured
    Screen 0 "A19-3A" 0 0
    InputDevice "USB Mouse"
    InputDevice "USB Keyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/misc"
    FontPath "/usr/share/fonts/TTF"
    FontPath "/usr/share/fonts/OTF"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/100dpi"
    FontPath "/usr/share/fonts/75dpi"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "record"
    Load "extmod"
    Load "xtrap"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "USB Keyboard"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    # Option "XkbOptions" "grp:toggle,grp_led:scrool"
    # Option "XkbVariant" ",winkeys"
    Option "XkbLayout" "dk"
    EndSection

    Section "InputDevice"
    Identifier "USB Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Protocol" "IMPS2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
    Option "SendCoreEvents" "true"
    # Option "Buttons" "5"
    EndSection


    Section "Monitor"
    Identifier "19tommer"
    VendorName "Fujitsu-Siemens"
    ModelName "A19-3A"
    EndSection

    Section "Device"
    ###Available Driver Options Are:-
    ###Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ###<string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ###[arg]: arg optional
    #Option "NoAccel" # [<bool>]
    #Option "SWcursor" # [<bool>]
    #Option "ColorKey" # <i>
    #Option "CacheLines" # <i>
    #Option "Dac6Bit" # [<bool>]
    #Option "DRI" # [<bool>]
    #Option "NoDDC" # [<bool>]
    #Option "ShowCache" # [<bool>]
    #Option "XvMCSurfaces" # <i>
    #Option "PageFile" # [<bool>]
    Identifier "Card0"
    Driver "intel"
    Vendorname "Intel Corporation"
    BoardName "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
    BusID "PCI:0:2:0"
    EndSection


    Section "Screen"
    Identifier "A19-3A"
    Device "Card0"
    Monitor "19tommer"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024" "1024x768" "800x600"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    End Section

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Does it stop working in moment you go into X or at a random point?

    If it's the former, then maybe you updated X recently, in such case you might have hit the infamous hal+evdev combo, which will require some fixes in your xorg.conf and in some other file.

    To be sure I need to know the version of xorg you are using, please, post the output of this command:

    Code:
    emerge -pv xorg-server
    Oh, also fix this line in your make.conf:

    Code:
    INPUT_DEVICES="evdev keyboard mouse"
    Note that's "evdev", not "endev" as you have.

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    13
    First thanks

    They stop working at the same moment when I can see the "X" on the screen, not at random point.

    I corrected the problem in my make.conf thanks for see that typo.

    when I make that "emerge -pv xorg-server"

    I get one ebuild N and one ebuild R.
    But I have already emerge that one time before..

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by hj3lmen View Post
    First thanks

    They stop working at the same moment when I can see the "X" on the screen, not at random point.

    I corrected the problem in my make.conf thanks for see that typo.

    when I make that "emerge -pv xorg-server"

    I get one ebuild N and one ebuild R.
    But I have already emerge that one time before..
    Since xorg-server 1.5 X uses hal+evdev for autoconfiguration of the mouses and keyboards, in my opinion it's not ready as you can see, but that's the way that things are going so we better adapt to that.

    You had not evdev in your input_devices, due to that typo, that means that you probably have no driver at the current moment to handle those. So, emerge xorg-server again doing this:

    Code:
    emerge -1 xorg-server
    Probably xorg-server and xf86-input-evdev will be merged again, that's right.

    After that you need to do a few things, while that emerges I will post here a revised version of your xorg.conf for evdev, and give additional instructions then. Stay tuned.

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Code:
    Section "ServerLayout"
    Identifier ""X.org Configured
    Screen 0 "A19-3A" 0 0
    #InputDevice "USB Mouse"
    #InputDevice "USB Keyboard"
    EndSection
    
    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/misc"
    FontPath "/usr/share/fonts/TTF"
    FontPath "/usr/share/fonts/OTF"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/100dpi"
    FontPath "/usr/share/fonts/75dpi"
    EndSection
    
    Section "Module"
    Load "dri"
    Load "dbe"
    Load "record"
    Load "extmod"
    Load "xtrap"
    Load "glx"
    EndSection
    
    #Section "InputDevice"
    #Identifier "USB Keyboard"
    #Driver "keyboard"
    #Option "CoreKeyboard"
    #Option "XkbRules" "xorg"
    #Option "XkbModel" "pc104"
    # Option "XkbOptions" "grp:toggle,grp_led:scrool"
    # Option "XkbVariant" ",winkeys"
    #Option "XkbLayout" "dk"
    #EndSection
    
    #Section "InputDevice"
    #Identifier "USB Mouse"
    #Driver "mouse"
    #Option "CorePointer"
    #Option "Protocol" "IMPS2"
    #Option "Device" "/dev/input/mice"
    #Option "ZAxisMapping" "4 5 6 7"
    #Option "SendCoreEvents" "true"
    # Option "Buttons" "5"
    #EndSection
    
    
    Section "Monitor"
    Identifier "19tommer"
    VendorName "Fujitsu-Siemens"
    ModelName "A19-3A"
    EndSection
    
    Section "Device"
    ###Available Driver Options Are:-
    ###Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ###<string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ###[arg]: arg optional
    #Option "NoAccel" # [<bool>]
    #Option "SWcursor" # [<bool>]
    #Option "ColorKey" # <i>
    #Option "CacheLines" # <i>
    #Option "Dac6Bit" # [<bool>]
    #Option "DRI" # [<bool>]
    #Option "NoDDC" # [<bool>]
    #Option "ShowCache" # [<bool>]
    #Option "XvMCSurfaces" # <i>
    #Option "PageFile" # [<bool>]
    Identifier "Card0"
    Driver "intel"
    Vendorname "Intel Corporation"
    BoardName "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
    BusID "PCI:0:2:0"
    EndSection
    
    
    Section "Screen"
    Identifier "A19-3A"
    Device "Card0"
    Monitor "19tommer"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024" "1024x768" "800x600"
    EndSubSection
    EndSection
    
    Section "DRI"
    Mode 0666
    End Section
    Backup your xorg.conf and use this one instead. Once we get everything working you can completely remove the input related sections (I only commented # them).

    After you do that you need to do this:

    Code:
    cp /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi /etc/hal/fdi/policy/
    After that, try to boot X again and let's see what happens. If it works your keyboard will probably be not configured for your language. That's fine, we'll fix that later..

  6. #6
    Just Joined!
    Join Date
    Apr 2009
    Posts
    13
    thanks again

    but: No that didn't do the trick.

    I did all that you mention that I should do but when I tryed to fireup : startx they still freezed so I had to take the powercore again

    I first did:
    emerge -1 xorg-server

    then

    nano -w /etc/X11/xorg.conf (to your re-configuretion of mine)

    then

    cp /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi /etc/hal/fdi/policy/

    and then i firedup: startx but still it freezed up.. :-/

  7. #7
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Then it's time to see your Xorg.0.log file. It's at /var/log, paste it in pastebin.com and put a link here to it. The file is re-created each time you fire up xorg.

  8. #8
    Just Joined!
    Join Date
    Apr 2009
    Posts
    13
    i mounted usb flash drive and took it over to my other PC - so here it is..


    ehmm.. I cant give you the URL because I don't have made 15posts yet to have that primissions.. rofl I just say..

    but i will copy it in here then..


    X.Org X Server 1.5.3
    Release Date: 5 November 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.27-gentoo-r10 i686
    Current Operating System: Linux Tux 2.6.27-gentoo-r10 #1 SMP Wed Apr 22 18:57:43 CEST 2009 i686
    Build Date: 23 April 2009 02:34:23PM

    Before reporting problems, check X.Org Wiki - Home
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 23 14:51:06 2009
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "X.org Configured"
    (**) |-->Screen "A19-A3" (0)
    (**) | |-->Monitor "19tommer"
    (**) | |-->Device "Card0"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/misc/").
    (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/OTF" does not exist.
    Entry deleted from font path.
    (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/misc/").
    (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/OTF" does not exist.
    Entry deleted from font path.
    (**) FontPath set to:
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/,
    built-ins
    (==) ModulePath set to "/usr/lib/xorg/modules"
    (II) Cannot locate a core pointer device.
    (II) Cannot locate a core keyboard device.
    (II) The server relies on HAL to provide the list of input devices.
    If no devices become available, reconfigure HAL or disable AllowEmptyInput.
    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    (II) No APM support in BIOS or kernel
    (II) Loader magic: 0x9a0
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 4.1
    X.Org XInput driver : 2.1
    X.Org Server Extension : 1.1
    (II) Loader running on linux
    (--) using VT number 7

    (--) PCI:*(0@0:2:0) Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller rev 3, Mem @ 0xf0000000/0, 0xd0000000/0, 0xf0300000/0, I/O @ 0x00001800/0
    (--) PCI: (0@0:2:1) Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller rev 3, Mem @ 0xf0080000/0
    (II) System resource ranges:
    [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
    [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
    [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
    [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
    [5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
    (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded. This was enabled by default and also specified in the config file.
    (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
    (II) LoadModule: "dri"

    (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dbe"

    (II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "record"

    (II) Loading /usr/lib/xorg/modules/extensions//librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension RECORD
    (II) LoadModule: "extmod"

    (II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension SHAPE
    (II) Loading extension MIT-SUNDRY-NONSTANDARD
    (II) Loading extension BIG-REQUESTS
    (II) Loading extension SYNC
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XC-MISC
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-Misc
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension TOG-CUP
    (II) Loading extension Extended-Visual-Information
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "xtrap"

    (II) Loading /usr/lib/xorg/modules/extensions//libxtrap.so
    (II) Module xtrap: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension DEC-XTRAP
    (II) LoadModule: "glx"

    (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
    (II) Module glx: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org Server Extension, version 1.1
    (==) AIGLX enabled
    (==) Exporting typical set of GLX visuals
    (II) Loading extension GLX
    (II) LoadModule: "intel"

    (II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
    (II) Module intel: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 2.6.3
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 4.1
    (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
    E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35, 965Q, 946GZ,
    965GM, 965GME/GLE, G33, Q35, Q33,
    Mobile Intel® GM45 Express Chipset,
    Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41
    (II) Primary Device is: PCI 00@00:02:0
    (II) resource ranges after xf86ClaimFixedResources() call:
    [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
    [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
    [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
    [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
    [5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
    (II) resource ranges after probing:
    [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
    [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
    [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
    [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [4] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
    [5] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
    [6] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
    [7] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
    [8] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
    [9] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
    [10] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"

    (II) Loading /usr/lib/xorg/modules//libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 0.1.0
    ABI class: X.Org Video Driver, version 4.1
    (==) intel(0): Depth 24, (--) framebuffer bpp 32
    (==) intel(0): RGB weight 888
    (==) intel(0): Default visual is TrueColor
    (II) intel(0): Integrated Graphics Chipset: Intel(R) 945GM
    (--) intel(0): Chipset: "945GM"
    (--) intel(0): Linear framebuffer at 0xD0000000
    (--) intel(0): IO registers at addr 0xF0000000
    (WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
    (==) intel(0): Using EXA for acceleration
    (II) intel(0): 2 display pipes available.
    (II) Loading sub module "ddc"
    (II) LoadModule: "ddc"
    (II) Module "ddc" already built-in
    (II) Loading sub module "i2c"
    (II) LoadModule: "i2c"
    (II) Module "i2c" already built-in
    (II) intel(0): Output VGA using monitor section 19tommer
    (II) intel(0): Output LVDS has no monitor section
    (II) intel(0): I2C bus "LVDSDDC_C" initialized.
    (II) intel(0): Attempting to determine panel fixed mode.
    (II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.
    (II) intel(0): I2C device "LVDSDDC_C:ddc2" removed.
    (II) intel(0): I2C bus "SDVOCTRL_E for SDVOB" initialized.
    (II) intel(0): I2C device "SDVOCTRL_E for SDVOB:SDVO Controller B" registered at address 0x70.
    (II) intel(0): I2C bus "SDVOB DDC Bus" initialized.
    (II) intel(0): Output TMDS-1 has no monitor section
    (II) intel(0): SDVOB: device VID/DID: 04:AA.03, clock range 25.0MHz - 165.0MHz
    (II) intel(0): SDVOB: 1 input channel
    (II) intel(0): SDVOB: TMDS0 output reported
    (II) intel(0): Current clock rate multiplier: 1
    (II) intel(0): Resizable framebuffer: not available (1 3)
    (II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.
    (II) intel(0): I2C device "LVDSDDC_C:ddc2" removed.
    (II) intel(0): I2C device "SDVOB DDC Bus:ddc2" registered at address 0xA0.
    (II) intel(0): I2C device "SDVOB DDC Bus:ddc2" removed.
    (II) intel(0): I2C bus "CRTDDC_A" initialized.
    (II) intel(0): I2C device "CRTDDC_A:ddc2" registered at address 0xA0.
    (II) intel(0): I2C device "CRTDDC_A:ddc2" removed.
    (II) intel(0): I2C bus "CRTDDC_A" removed.
    (II) intel(0): EDID vendor "FUS", prod id 1672
    (II) intel(0): Output VGA disconnected
    (II) intel(0): Output LVDS connected
    (II) intel(0): Output TMDS-1 connected
    (II) intel(0): Using user preference for initial modes
    (II) intel(0): Output LVDS using initial mode 800x600
    (II) intel(0): Output TMDS-1 using initial mode 1280x1024
    (II) intel(0): detected 256 kB GTT.
    (II) intel(0): detected 7932 kB stolen memory.
    (==) intel(0): video overlay key set to 0x101fe
    (==) intel(0): Will not try to enable page flipping
    (==) intel(0): Triple buffering disabled
    (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
    (==) intel(0): DPI set to (96, 96)
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"

    (II) Loading /usr/lib/xorg/modules//libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "exa"
    (II) LoadModule: "exa"

    (II) Loading /usr/lib/xorg/modules//libexa.so
    (II) Module exa: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 2.4.0
    ABI class: X.Org Video Driver, version 4.1
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Module "ramdac" already built-in
    (II) intel(0): Comparing regs from server start up to After PreInit
    (==) Depth 24 pixmap format is 32 bpp
    (II) do I need RAC? No, I don't.
    (II) resource ranges after preInit:
    [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
    [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
    [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
    [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [4] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
    [5] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
    [6] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
    [7] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
    [8] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
    [9] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    [10] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
    (II) intel(0): Kernel reported 810752 total, 1 used
    (II) intel(0): I830CheckAvailableMemory: 3243004 kB available
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    [drm] failed to load kernel module "i915"
    (EE) [drm] drmOpen failed.
    (EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
    (**) intel(0): Framebuffer compression enabled
    (**) intel(0): Tiling enabled
    (==) intel(0): VideoRam: 262144 KB
    (II) intel(0): Attempting memory allocation with tiled buffers.
    (II) intel(0): Tiled allocation successful.
    (II) intel(0): adjusting plane->pipe mappings to allow for framebuffer compression
    (II) intel(0): Page Flipping disabled
    (II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
    (II) EXA(0): Offscreen pixmap area of 34406400 bytes
    (II) EXA(0): Driver registered support for the following operations:
    (II) Solid
    (II) Copy
    (II) Composite (RENDER acceleration)
    (==) intel(0): Backing store disabled
    (==) intel(0): Silken mouse enabled
    (II) intel(0): Initializing HW Cursor
    (II) intel(0): Current clock rate multiplier: 1
    (II) intel(0): xf86BindGARTMemory: bind key 0 at 0x01000000 (pgoffset 4096)
    (II) intel(0): xf86BindGARTMemory: bind key 1 at 0x02000000 (pgoffset 8192)
    (II) intel(0): Fixed memory allocation layout:
    (II) intel(0): 0x00000000-0x0001ffff: ring buffer (128 kB)
    (II) intel(0): 0x00020000-0x0061ffff: compressed frame buffer (6144 kB, 0x00000000cf820000 physical
    )
    (II) intel(0): 0x00620000-0x00620fff: compressed ll buffer (4 kB, 0x00000000cfe20000 physical
    )
    (II) intel(0): 0x00621000-0x0062afff: HW cursors (40 kB, 0x00000000cfe21000 physical
    )
    (II) intel(0): 0x0062b000-0x0072afff: fake bufmgr (1024 kB)
    (II) intel(0): 0x0072b000-0x0072bfff: overlay registers (4 kB, 0x00000000cff2b000 physical
    )
    (II) intel(0): 0x007bf000: end of stolen memory
    (II) intel(0): 0x01000000-0x01ffffff: front buffer (16384 kB)
    (II) intel(0): 0x02000000-0x040cffff: exa offscreen (33600 kB)
    (II) intel(0): 0x10000000: end of aperture
    (II) intel(0): Selecting standard 18 bit TMDS pixel format.
    (II) intel(0): Output configuration:
    (II) intel(0): Pipe A is on
    (II) intel(0): Display plane B is now enabled and connected to pipe A.
    (II) intel(0): Pipe B is on
    (II) intel(0): Display plane A is now enabled and connected to pipe B.
    (II) intel(0): Output VGA is connected to pipe none
    (II) intel(0): Output LVDS is connected to pipe B
    (II) intel(0): Output TMDS-1 is connected to pipe A
    (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    (II) intel(0): DPMS enabled
    (==) intel(0): Intel XvMC decoder disabled
    (II) intel(0): Set up textured video
    (II) intel(0): Set up overlay video
    (II) intel(0): direct rendering: Failed
    (--) RandR disabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (II) AIGLX: Screen 0 is not DRI capable
    (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
    (II) GLX: Initialized DRISWRAST GL provider for screen 0
    (II) intel(0): Setting screen physical size to 338 x 270

  9. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    13
    there i got it..

  10. #10
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    I suspect that log is not complete. Most forums have a cap on how big a single post can be.

    Try to mail the log file to me as an attachment in that case. There's an error about drm on that part of the log that I can see, but that doesn't seem related to this question at all so we can worry about that later.

    EDITED: Oh, as a note, you can "emerge wgetpaste". That tool will allow you to upload files to a pastebin from the command line, and it will give you an url after that where you can see that contents you just uploaded. Nifty little tool.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •