Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I have a curious, stubborn problem with Gnome: I can't set file permissions on my /home partition. I have mounted the partition with noatime,defaults options and have granted all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    Gnome refuses to set file permissions


    Hello,

    I have a curious, stubborn problem with Gnome: I can't set file permissions on my /home partition. I have mounted the partition with noatime,defaults options and have granted all users rwxrwxrwx permissions. Despite 777 permissions, Nautilus shows my /home partition as having folder access 777 yet file access 000. It's driving me cuckoo, just look at this:

    Code:
    img147.imageshack.us/img147/781/screenshotsxc.png
    
    
    (yeah, I can't post URLs or images yet, fantastic)
    Whenever I try to tick a box under 'file permissions', it flips right back to negative. I can run Linux games fine, but this problem prevents, by instance, Wine from functioning properly, as it doesn't have write access. Below are some relevant details.

    Operating system: Gentoo ~amd64
    File system type: ext4
    Gnome version: 2.24
    Hard drive: 1 TB SATA

    I've already visited 4 forums, but nobody could help me with this problem. Is it a bug in GnomeVFS? Is it a Nautilus setting I haven't found? Do I have to fiddle with GConf? I have absolutely no idea. Please help.

    Thanks in advance,

    Itzamna

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Try
    Code:
    su -
    chmod -R 777 /home/itzamna
    Though I think setting your home directory to rwx for everyone is a terrible idea.

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2
    Hello Reed9, thanks for your response. I have found a workaround for my specific problem with Wine, so I'll just leave this Nautilus oddity as it is. If you want to know exactly what workaround, check:

    forum.winehq.org/viewtopic.php?p=23911#23911

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •