Find the answer to your Linux question:
Results 1 to 2 of 2
I just installed Gentoo .. But unluckily i was caught in between Xorg and Final run of my Gentoo. Probably it wont matter u guys , but as a newbie ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    19

    Anyone sound in Xorg?


    I just installed Gentoo .. But unluckily i was caught in between Xorg and Final run of my Gentoo.
    Probably it wont matter u guys , but as a newbie its being irritating ..
    I'll post what i've done till date

    1 . Installation complete and I need to get started with GUI , Xorg was the option specified in handbook , is there any other , please let me know about that also ..
    2. when typed command emerge xorg-x11 [ let me post the last portion , since its making problem]

    >>> Installing x11-libs/libICE-1.0.4

    >>> Emerging (4 of 86) net-misc/netkit-rsh-0.17-r9
    * netkit-rsh-0.17.tar.gz RMD160 SHA1 SHA256 size
    * netkit-rsh-0.17-patches-2.tar.lzma RMD160 SHA1 SHA256 size
    * rexec-1.5.tar.gz RMD160 SHA1 SHA256 size
    * checking ebuild checksums
    * checking auxfile checksums
    * checking miscfile checksums
    >>> Unpacking source...
    >>> Unpacking rexec-1.5.tar.gz to /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work
    >>> Unpacking netkit-rsh-0.17-patches-2.tar.lzma to /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work
    >>> Unpacking netkit-rsh-0.17.tar.gz to /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work
    rm: cannot remove directory `rexec': Directory not empty
    * Applying various patches (bugfixes/updates) ...
    * 000_all_sectty.patch ... [ ok ]
    * 010_all_rexec.patch ...

    * Failed Patch: 010_all_rexec.patch !
    * ( /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work/patch/010_all_rexec.patch )
    *
    * Include in your bugreport the contents of:
    *
    * /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/010_all_rexec.patch-5091.out

    *
    * ERROR: net-misc/netkit-rsh-0.17-r9 failed.
    * Call stack:
    * ebuild.sh, line 49: Called src_unpack
    * environment, line 2273: Called epatch '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work/patch'
    * environment, line 1166: Called die
    * The specific snippet of code:
    * die "Failed Patch: ${patchname}!";
    * The die message:
    * Failed Patch: 010_all_rexec.patch!
    *
    * If you need support, post the topmost build error, and the call stack if relevant.
    * A complete build log is located at '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/environment'.
    *

    >>> Failed to emerge net-misc/netkit-rsh-0.17-r9, Log file:

    >>> '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/build.log'

    * Messages for package net-misc/netkit-rsh-0.17-r9:

    * Failed Patch: 010_all_rexec.patch !
    * ( /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work/patch/010_all_rexec.patch )
    *
    * Include in your bugreport the contents of:
    *
    * /var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/010_all_rexec.patch-5091.out
    *
    * ERROR: net-misc/netkit-rsh-0.17-r9 failed.
    * Call stack:
    * ebuild.sh, line 49: Called src_unpack
    * environment, line 2273: Called epatch '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/work/patch'
    * environment, line 1166: Called die
    * The specific snippet of code:
    * die "Failed Patch: ${patchname}!";
    * The die message:
    * Failed Patch: 010_all_rexec.patch!
    *
    * If you need support, post the topmost build error, and the call stack if relevant.
    * A complete build log is located at '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/net-misc/netkit-rsh-0.17-r9/temp/environment'.
    *

    * GNU info directory index is up-to-date.
    linux_boy-localhost / # Xorg -configure
    bash: Xorg: command not found

    So my question is there anything which i can have Xorg configuration back , and complete my installation

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,042
    Quote Originally Posted by Linux_Boy View Post
    I just installed Gentoo .. But unluckily i was caught in between Xorg and Final run of my Gentoo.
    ...I'll post what i've done till date

    1 . Installation complete and I need to get started with GUI , Xorg was the option specified in handbook , is there any other , please let me know about that also ..
    2. when typed command emerge xorg-x11 [ let me post the last portion , since its making problem]

    >>> Installing x11-libs/libICE-1.0.4

    >>> Emerging (4 of 86) net-misc/netkit-rsh-0.17-r9
    ....
    linux_boy-localhost / # Xorg -configure
    bash: Xorg: command not found

    So my question is there anything which i can have Xorg configuration back , and complete my installation
    From the information you have provided it looks as though your attempt to emerge xorg-x11 has failed ... note this failure happened at package 4 or 86 so xorg-x11 is not installed. This means attempting to configure X with Xorg -configure is a waste of time.

    I had quite a few problems when I first started to use Gentoo, some being caused by my choice of USE flags (the defaults did not work for me). I started this thread on USE flags which maybe worth you reviewing. Check you ran emerge --sync and emerge -pvuDN world before emerging X.

    Review the output message you get from emerge, and review the build.log it references and see if you can work out what is causing the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •